Opened 5 years ago

Closed 5 years ago

Last modified 7 months ago

#2065 closed defect (incomplete)

Element Hiding Rules No Longer Work in Firefox 36

Reported by: nonbongo Assignee: trev
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: arthur, mapx Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working:
Review URL(s):

Description

Environment

Xubuntu Linux 14.04 trusty (kernel: x86_64 Linux 3.13.0-46-generic)
Firefox 36.0
ABP 2.6.7
Filters = EasyPrivacy+EasyList, Fanboy's Annoyance List, Adblock Warning Removal List

How to reproduce

  1. Go to any website.
  2. Hide any element manually, or with the Element Hiding Helper.
  3. Watch the element disappear briefly, then reappear again.

Observed behaviour

Element hiding rules no longer work. I suspect this has something to do with the release of Firefox 36. I have tried reinstalling both ABP and the Element Hiding helper. I have tried clearing cookies and cache. I have tried a fresh profile. Nothing works.

Expected behaviour

Element hiding rules should work.

Change History (10)

comment:1 Changed 5 years ago by nonbongo

Others seem to be having this issue as well: https://adblockplus.org/forum/viewtopic.php?f=1&t=28431&start=0

comment:2 Changed 5 years ago by nonbongo

Some folks are saying that it appears to be a filter issue, because apparently restoring their oldest backup re-enables ABP's ability to hide elements.

comment:3 Changed 5 years ago by mapx

  • Cc arthur added
  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Owner set to trev

-it seems to be some wrong filter in easylist
To reproduce the issue:
-go to http://www.leftlanenews.com/
-create (EHH) some hiding filter ==> does not work
-if disable easylist and add EasyList without element hiding ==> will work

comment:4 Changed 5 years ago by mapx

  • Cc mapx added

comment:5 Changed 5 years ago by nonbongo

thank you for quickly getting on it! it is indeed an issue with easylist.

comment:6 Changed 5 years ago by fanboy

Okay I'm starting to hit this.

Firefox stable (Adblock Plus stable): http://i.imgur.com/MMRVkst.png
Firefox Nightly (Adblock Plus Dev): http://i.imgur.com/gme47nQ.png

1) Add the Annoyances List
2) Visit http://www.timesofisrael.com/israel-said-to-seek-additional-300-million-for-missile-defense/
3) The popup at the bottom should be hidden, and "free signup" in article should be also gone.

Note: If you manually add these filters it hides them.

timesofisrael.com###slidebox
timesofisrael.com###article-promo

Bug seems to the with the ",", because this fails:

bob.com,timesofisrael.com###slidebox
bob.com,timesofisrael.com###article-promo

comment:7 Changed 5 years ago by fanboy

Okay I've found the issue, should be fixed. Force an update.

https://hg.adblockplus.org/easylist/rev/6965d551bf30

comment:8 Changed 5 years ago by mapx

Which was the error ?

And why chrome wasn't affected ? (could be #521 issue for FF ? )

comment:9 Changed 5 years ago by trev

  • Resolution set to incomplete
  • Status changed from new to closed

Ok, so the issue was a missing quotation mark in the extratorrent.cc filter in EasyList. No Adblock Plus bug here (#521 is unrelated), this is just how element hiding works.

Chrome was likely affected as well, but element hiding works differently there so this filter didn't have any global impact. Note that in Chrome we are already validating element hiding filters when they are added, the same mechanism should be added in Firefox as well soon.

comment:10 Changed 5 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.