Opened 4 years ago

Closed 4 years ago

#2079 closed defect (fixed)

Opera doesn't switch to options tab

Reported by: passbrains Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-1.8.12-for-Chrome-Opera-Safari
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Opera
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/5455624317960192

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-195

Environment

Windows + 8 64bit + Opera + Russian
ABP version for Opera 1.8.11.1365

How to reproduce

1) I have 10+ tabs opened. One of the tab is Adblock Plus settings.
2) For example, i navigate to translate.google and now i want to see Adblock Plus settings, I forget that Adblock Plus settings tab is already open.
3) Cliсk Adblock Plus Icon.
4) Click on  "Settings".

Observed behaviour

The options tab is merely highlighted, but doesn't become active.

Expected behaviour

The existing options tab should be focused.

Attachments (1)

7058_1425316818_settings_button.jpg (310.6 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by sebastian

  • Description modified (diff)
  • Owner set to sebastian
  • Ready set

Interestingly, Opera only highlights the options tab, but doesn't switch there. This is an Opera bug. The issue isn't reproducible with Chrome. It were probably introduced with #1820 when we moved to chrome.tabs.highlight because chrome.tabs.update(tabId, {selected: true} is deprecated.

comment:2 Changed 4 years ago by sebastian

  • Priority changed from Unknown to P2

comment:3 Changed 4 years ago by sebastian

I reported the bug to Opera. It is tracked as "DNA-35196", however their bug tracker isn't public.

comment:4 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 4 years ago by sebastian

  • Description modified (diff)
  • Summary changed from Settings link is not correct. to Opera doesn't switch to options tab

comment:6 Changed 4 years ago by sebastian

Maybe this isn't actually a bug in Opera but in Chrome. The documentation doesn't really say whether "highlighting" a tab implies selecting it. However, it seems that chrome.tabs.update(id {active: true})is rather what we want here.

comment:7 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.