Opened 5 years ago

Closed 5 years ago

#2081 closed defect (fixed)

"Block element" is available from the popup even if adblocking is disabled on the current page

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.12-for-Chrome-Opera-Safari
Module: User-Interface Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/6257417939582976

Description

Environment

Chrome, Opera or Safari

How to reproduce

  1. Go to any website (e.g. https://adblockplus.org)
  2. Click the ABP toolbar icon
  3. Disable Adblock Plus on this site

Observed behaviour

The "Block element" option is still available. But since the current page is whitelisted added filters won't have any effect after reload. The "Block element" context menu item is removed from whitelisted pages however.

Expected behaviour

The "Block element" item should be hidden in the popup if the current page is whitelisted.

Change History (2)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.