Opened 4 years ago

Closed 4 years ago

#2084 closed defect (fixed)

Placeholders show up in dynamically created frames

Reported by: sebastian Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-1.8.12-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/6677078657204224

Description

Environment

Chrome and Opera, not in Safari
Adblock Plus 1.8.10 and current devbuild
EasyList Germany + Acceptable Ads

How to reproduce

  1. Go to http://www.chip.de/News_29559209.html
  2. Scroll down to the blocked ad banners

Observed behaviour

Placeholder show up, where the ad banners were. That is because the surrounding frame is dynamically created. Those frames are usually considered, but the way those particular frames are created here contentDocument.location is the top-level URL instead about:blank, bypassing our detection. This is a regression introduced with #1977, where that detection has been adjusted to fix another bug.

Expected behaviour

No placeholders for blocked elements should show up.

Change History (2)

comment:1 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.