Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#209 closed defect (worksforme)

Video ads and ads within videos are not being blocked.

Reported by: Regifishy Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Windows 8.1 (although it was doing this with Vista when I had it installed as well), Google Chrome Version 33.0.1750.154 m, AB+ Ver. 1.7.4, with EasyList Enabled.

How to reproduce

  1. Go to any website that uses video ads, in-video ads, or has Flash as a primary viewing app.
  1. Watch anything and become bewildered by the spontaneous appearance of advertisements popping up in the flash enabled zone (It only seems to have this behavior with videos that use flash player, as HTML5 and silverlight, in addition flash based ads fail to manifest any abnormal behaviors.)

...

Observed behaviour

Eveytime I use the external flash player, AB+ fails to block both in-video ads and video ads. This only happens with flash based videos; HTML5 and silverlight remain untouched by abnormalities and flash based ads fail to appear (As they should.)

As stated earlier, this problem only occurs when using the external flash, not google's integrated pepperflash. Peperflash, however lags profusely during video-viewing and renders said content nearly indecipherable (It does, however block all advertisements.

Expected behaviour

I'd hope that AB+ (Apologies for the abbreviation...) would behave the same way with the external flash player as it would with the integrated (And far inferior) chrome player. It has been doing this since late January and before I switched to Windows 8.1, it does not exhibit the same bugs with Firefox (Which uses the external flash plugin) so it may be a problem with Chrome rather than the plugin, but someone here might know what to do.

Change History (3)

comment:2 Changed 5 years ago by philll

  • Resolution set to worksforme
  • Status changed from new to closed

Apart from the issue noted by mapx, this works fine for me with the examples I have tried. If you are still facing this issue with having implemented mapx' suggestion, please reopen this issue with some sample URLs.

comment:3 Changed 5 years ago by Regifishy

NPAPI is what causes the ads and stuff to appear and PPAPI causes tremendous amounts of lag, so much so that the video is barely viewable. (No ads on ppapi.)

Oh, so it was Google's fault...

Note: See TracTickets for help on using tickets.