Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#211 closed change (fixed)

[trac] Make priority/milestone/component fields visible to everybody

Reported by: trev Assignee: trev
Priority: P2 Milestone:
Module: Infrastructure Keywords:
Cc: Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: yes
Review URL(s):

http://codereview.adblockplus.org/5769066073554944/

Description

Background

Currently we hide fields that the user isn't allowed to edit. That has the side-effect however that these fields are also hidden in the issue summary or issue listing. This information is important however and needs to be shown to everybody.

What to change

Show fields like priority/milestone/component in the issue summary but keep them hidden when the issue is created and the user doesn't have the permission to change them.

Change History (8)

comment:1 Changed 6 years ago by trev

Looking into the blackmagic plugin, there really seem to be only two options: "hide" will hide the field everywhere, "disable" will show it but it will also show the edit field (which will be disabled, with the label crossed out). The following CSS code should do the job however:

  label[for^="field-"] > strike,
  [id^="field-"][disabled]
  {
    display: none;
  }

Given that blackmagic doesn't remove the table cells but only the text within, the job done by this CSS code isn't any worse.

comment:2 Changed 6 years ago by trev

  • in_progress changed from 0 to 1
  • Owner set to trev
  • Status changed from new to assigned

comment:3 Changed 6 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from assigned to reviewing

comment:4 Changed 6 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 6 years ago by philll

Looks good apart from http://trac.edgewall.org/ticket/11560 when regarding the review_URL field.

comment:6 Changed 6 years ago by trev

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening due to issues with hiding the "Review URL(s)" field as well as a missing dependency in Puppet.

comment:7 Changed 6 years ago by trev

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:8 Changed 6 years ago by philll

  • Verified working set
Note: See TracTickets for help on using tickets.