Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2117 closed defect (rejected)

On Chrome ABP eats a lot of memory

Reported by: dadexix86 Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, mapx Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Verified working:
Review URL(s):

Description

Environment

Ubuntu GNU/Linux 14.04
Chrome Version 41.0.2272.76
AdBlockPlus Version 1.8.11

How to reproduce

  1. Disable ABP, restart your browser and open a bunch of pages, in this case just three: Gmail, Spotify and this Ticket.
  2. Look at the memory usage (http://i60.tinypic.com/2921hc6.png)
  3. Enable ABP, restart your browser and open the same bunch of pages
  4. Look at the memory usage (http://i59.tinypic.com/vhawjm.png)
  5. Be shocked by the difference

Observed behaviour

Active lists:
Adblock Warning Removal List
EasyList
EasyList Germany
EasyList Italy

ABP uses about 100MB more of RAM per open page, filling my RAM really quickly and, eventually, slowly killing the navigation speed, making it de-facto useless.

Expected behaviour

That it does not eat all this RAM allowing the navigation to be smooth even with more than 6 pages open.

Change History (7)

comment:1 Changed 5 years ago by mapx

  • Cc sebastian mapx added
  • Component changed from Unknown to Platform

comment:2 in reply to: ↑ description Changed 5 years ago by sebastian

Replying to dadexix86:

EasyList
EasyList Germany
EasyList Italy

Is it possibly that you have subscribed to "EasyList", "EasyList Germany+EasyList" and "EasyList Italy+EasyList"? That would mean that you have 3 copies of EasyList itself, which would certainly explain higher than usual memory usage. If that is the case or if you aren't sure, remove those subscriptions and subscribe following URLs instead:
https://easylist-downloads.adblockplus.org/easylist.txt
https://easylist-downloads.adblockplus.org/easylistitaly.txt
https://easylist-downloads.adblockplus.org/easylistgermany.txt

ABP uses about 100MB more of RAM per open page

That is not true according to your own screenshots. It's only ~100MB more for Gmail, which already uses ~318MB without Adblock Plus. On the other hand for Trac it's just 18MB more with ABP. Sill slightly more than usual, but not over the top considering that there need to be a stylesheet with a selector for each element hiding filter in every document, to block all ads.

comment:3 Changed 5 years ago by mapx

thread on forum:
https://adblockplus.org/forum/viewtopic.php?f=10&t=28637

initially there were 2 easylist, then (after my advice) not anymore

comment:4 Changed 5 years ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

Closing as rejected, since there is nothing we can do for now. The memory usage per tab mostly comes from the injected stylesheet. In the long term the filter hit stats (#495) will hopefully provide data to identify and strip out unneeded filters. And with Typed Objects (#145) we try to reduce the memory usage of the extension itself, however this won't have any effect on the memory usage per tab. But this is all we can do (without introducing other issues), the way Chrome works and allows to hide elements.

Last edited 5 years ago by sebastian (previous) (diff)

comment:5 Changed 5 years ago by dadexix86

This is sad :(

But thanks for taking some time to look at the problem! :)

comment:6 Changed 5 years ago by sebastian

As a workaround, you could disable element hiding:
@@||*^$elemhide

Or only for websites you frequently visit that tend to use a lot of memory like Gmail:
@@||mail.google.com^$elemhide

However, this will unblock some ads, but should significantly reduce the memory usage per tab.

comment:7 Changed 5 years ago by mapx

or ...you could use directly EasyList without element hiding
from: https://easylist.adblockplus.org/en/

Note: See TracTickets for help on using tickets.