Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#214 closed defect (fixed)

ABP forum just shows an nginx error

Reported by: philll Assignee: trev
Priority: P1 Milestone:
Module: Infrastructure Keywords:
Cc: Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: yes
Review URL(s):

Description

How to reproduce

  1. Go to https://adblockplus.org/forum/

Observed behaviour

The following note is displayed:

An error occurred.

Sorry, the page you are looking for is currently unavailable.
Please try again later.

If you are the system administrator of this resource then you should check the error log for details.

Faithfully yours, nginx.

Expected behaviour

The Forum should be displayed

Change History (8)

comment:1 Changed 6 years ago by trev

Looks like the cron jobs hanged up and made this server run out of memory...

comment:2 Changed 6 years ago by trev

  • Resolution set to fixed
  • Status changed from new to closed

Fixed but not really sure about what caused this issue. The issue report processing jobs started piling up, first issue reported at 8:27 today. It seems that the database was the bottleneck here, right now there isn't any noteworthy load there however.

comment:3 Changed 6 years ago by philll

  • Verified working set

comment:4 Changed 6 years ago by trev

I think it is simply way too much running on that one server...

comment:5 Changed 6 years ago by trev

Actually, what apparently made this box run out of memory was AWStats.

comment:6 Changed 6 years ago by philll

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Verified working unset

The forum does not respond in reasonable time again, and at some attempts also shows the nginx note.

comment:7 Changed 6 years ago by trev

  • Resolution set to fixed
  • Status changed from reopened to closed

The tasks that were supposed to finish overnight were still executing, all at once. That caused a rather high load on that server. The load already went way down, in the current state I would consider it acceptable. Resolving again.

The long term solution is of course migrating more tasks away from that server, this is in progress already.

comment:8 Changed 6 years ago by philll

  • Verified working set
Note: See TracTickets for help on using tickets.