Opened 5 years ago

Closed 5 years ago

#2145 closed defect (fixed)

[cms] Strings from random locales show up on "English" pages

Reported by: trev Assignee: trev
Priority: P2 Milestone:
Module: Sitescripts Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/5361415552499712/

Description

How to reproduce

  1. Run python -m cms.bin.generate_static_pages on the web.adblockplus.org repository.
  2. Inspect the results, e.g. the en/about file.

Observed behaviour

Menu contains strings from random languages.

Expected behaviour

Menu language should be English only.

Background

The problem is due to the dictionary returned by source.read_locale() being modified. python -m cms.bin.generate_static_pages memoizes the result of this call, so on subsequent calls the same modified dictionary will be returned.

Change History (2)

comment:1 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.