Opened 5 years ago

Closed 5 years ago

#2153 closed change (duplicate)

Improve ENC by removing hiera/private requirement

Reported by: matze Assignee: matze
Priority: P3 Milestone:
Module: Infrastructure Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

Description

The External Node Classifier and Hiera (see #112) could be improved by removing the requirement for the new hiera/private directory and instead declaring modules/private/hiera as the canonical path for private hiera configuration.

What to change

  • Ensure hiera/hiera.yaml reflects the canonical path and improve the :hierarchy: accordingly
  • Update both the hiera/install_precise.py and the hiera/puppet_node_classifier.rb script to feature the new canonical path
  • Remove or replace the related documentation in README.md
  • Anything that may be necessary but has been forgotten here :)

Change History (1)

comment:1 Changed 5 years ago by matze

  • Resolution set to duplicate
  • Status changed from new to closed

Accidental duplicate of #2154.

Note: See TracTickets for help on using tickets.