Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#216 closed defect (fixed)

Firefox - First run page opens on every update

Reported by: trev Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.6-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: Blocked By:
Blocking: #153 Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5689385303408640

Description (last modified by trev)

Environment

Adblock Plus 2.5.1.3786 in Firefox 31.0a1 nightly on OS X.

How to reproduce

  1. Install Adblock Plus 2.5.1.3785 from https://downloads.adblockplus.org/devbuilds/adblockplus/.
  2. Force extension update to have it update to Adblock Plus 2.5.1.3786.

Observed behaviour

First run page opens on update, filter subscriptions don't change.

Expected behaviour

No first run on update unless there is really no filter subscription installed.

Change History (6)

comment:1 Changed 5 years ago by trev

  • Description modified (diff)

comment:2 Changed 5 years ago by trev

Apparently, the issue is that FilterStorage._loading is being set too late. Timing changes caused by #153 are triggering that issue now, before that IO.statFile() was synchronous and this issue didn't matter.

comment:3 Changed 5 years ago by trev

  • Blocking 153 added
  • in_progress changed from 0 to 1
  • Owner set to trev
  • Review URL(s) modified (diff)
  • Status changed from new to assigned

comment:4 Changed 5 years ago by trev

  • Status changed from assigned to reviewing

comment:5 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
Note: See TracTickets for help on using tickets.