Opened 4 years ago

Closed 4 years ago

#2172 closed defect (fixed)

Extension initialization fails on Safari <= 6

Reported by: sebastian Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-1.9-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/6595500853690368

Description

Environment

Safari 5.1, 6.0 and 6.1
Adblock Plus 1.8.12

How to reproduce

Open the icon popup and click "Options" for example.

Observed behaviour

The popup doesn't respond. That's because an error in the background page when calling new URL, since window.URL isn't supported on Safari 6 and earlier. There is a fallback implementation in lib/url.js but that script isn't loaded yet when running the code introduced with #2082 to detect existing tabs.

Expected behaviour

The extension including the icon popup should work on Safari 5.1 and above.

Change History (2)

comment:1 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.