Opened 6 years ago

Closed 4 years ago

#219 closed defect (fixed)

Donation page broken in IE 8

Reported by: philll Assignee:
Priority: P3 Milestone:
Module: Websites Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29334044/

Description (last modified by greiner)

Environment

Win 7 IE 8

How to reproduce

  1. Go to https://adblockplus.org/en/donate
  2. Select an amount by checking one of the radio buttons
  3. Click the "Donate" button

Observed behaviour

Nothing happens when the "Donate" button is clicked.

Expected behaviour

Like proceeding the same with another browser like Chrome, the respective payment site should open.

Change History (6)

comment:1 Changed 5 years ago by greiner

  • Description modified (diff)
  • Owner set to greiner
  • Status changed from new to assigned
  • Summary changed from Donation page broken in IE 6,7,8 to Donation page broken in IE 8

We discontinued support for Internet Explorer 6 and 7. Therefore I modified this issue to only mention Internet Explorer 8.

comment:2 Changed 5 years ago by philll

  • Status changed from assigned to new

The assigned state will be dropped by #403

comment:3 Changed 5 years ago by saroyanm

  • Component changed from Infrastructure to Websites
  • Platform set to Unknown

comment:4 Changed 5 years ago by greiner

  • Owner greiner deleted

comment:5 Changed 4 years ago by juliandoucette

  • Platform changed from Unknown to Internet Explorer
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing
  • Tester set to Unknown

It seems this site was generally not developed with IE<9 in mind.

This revision implements IE8 support for the donate form in donate.html in roughly
as few changes as possible. If we want to support IE8 sitewide, I would recommend
introducing a JavaScript library or select polyfills for IE<9 (which can be
included without slowing down pageload on other probsers via IFIE comments).

I found the following issues in donate.html

  • IE8 doesn't support addEventListener (use attachEvent and 'on' + event)
  • IE8 doesn't support DOMContentLoaded (use document readyState and onreadystatechange)
  • IE8 querySelector doesn't support :checked (use querySelectorAll and a function to return the checked checkbox)
  • IE8 doesn't support getElementsByClassName (use querySelectorAll)
  • IE8 event doesn't have target (use event.target or event.srcElement)
  • IE8 document.head is undefined (use document.getElementsByTagName('head')[0])
  • #form should be a form for accessibility (to conform to web standards)
  • form should submit event instead of click for accessibility (to conform to web standards)
  • Node.localName was removed from Chrome as of version 46, use tagName (this is out of scope for supporting IE8, but it is related because localName will not be supported by standards in the future)
  • IE8 buttons submit by default (use event.preventDefault() and event.returnValue = false)
Last edited 4 years ago by juliandoucette (previous) (diff)

comment:6 Changed 4 years ago by juliandoucette

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.