Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#2195 closed change (fixed)

Add notification opt-out to Chrome/Opera/Safari

Reported by: greiner Assignee: greiner
Priority: P2 Milestone: Adblock-Plus-1.9.1-for-Chrome-Opera-Safari
Module: User-Interface Keywords:
Cc: sebastian, sven Blocked By: #2192
Blocking: #2191, #2191, #2726 Platform: Unknown
Ready: yes Confidential: no
Tester: Ross Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29321084/

Description (last modified by greiner)

Background

In #2192 we added opt-out capabilities for notifications and we need to expose those in the extension UI.

What to change

Notification:

  • Upon clicking on the "x" in the notification shown in the icon popup, the notification content should be replaced with the following two links (see screenshot):
    • Close this notification: Hide the notification (current behavior of the "x" button)
    • Stop showing notifications: Hide the notification and add "*" to Prefs.notifications_ignoredcategories.

The following options should be hidden by default and only be shown if Prefs.notifications_showui is set to true:

Options page:

  • Add a checkbox "Show useful notifications" to the "General" tab in the options page (see screenshot).
  • This checkbox should toggle the "*" entry in Prefs.notifications_ignoredcategories.

Reuse the texts from the Firefox version as soon as #2193 is done to avoid string duplication.

Attachments (2)

notification-options_platform.png (21.9 KB) - added by greiner 5 years ago.
notification-popup_platform.png (39.5 KB) - added by greiner 5 years ago.

Download all attachments as: .zip

Change History (15)

Changed 5 years ago by greiner

Changed 5 years ago by greiner

comment:1 follow-up: Changed 5 years ago by sebastian

  • Cc sebastian added
  • Component changed from Platform to User-Interface

So the part in the options page will only be visible if Prefs.notifications_showcheckbox is set, but we never set that preference to true? Maybe we should just show the checkbox on the options page if the user has opted out from all notifications before, instead introducing a hidden preference.

comment:2 in reply to: ↑ 1 Changed 5 years ago by greiner

  • Blocking 2192 added; 2191 removed
  • Description modified (diff)

Replying to sebastian:

So the part in the options page will only be visible if Prefs.notifications_showcheckbox is set, but we never set that preference to true? Maybe we should just show the checkbox on the options page if the user has opted out from all notifications before, instead introducing a hidden preference.

That preference is being set as part of #2192. The problem is that if you don't have this preference then that option would disappear when someone unchecks it to opt-in again which is not a good user experience IMHO.

Therefore the logic is that the checkbox will stay visible after someone opted-out of a notification. Alternatively, we could always show the checkbox but that's how it was proposed in the preceding discussion.

comment:3 Changed 5 years ago by greiner

  • Blocked By 2192 added
  • Blocking 2191 added; 2192 removed

comment:4 Changed 5 years ago by greiner

  • Blocking

comment:5 Changed 5 years ago by sebastian

Ok, that makes sense I suppose.

comment:6 Changed 5 years ago by greiner

  • Cc sven added
  • Description modified (diff)
  • Verified working unset

Updated texts to make them shorter and more accurate following a discussion with Sven.

comment:7 Changed 5 years ago by greiner

  • Description modified (diff)
  • Owner set to greiner

comment:8 Changed 4 years ago by greiner

  • Description modified (diff)

comment:9 Changed 4 years ago by greiner

  • Ready set
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:10 Changed 4 years ago by greiner

  • Blocking 2726 added

comment:11 Changed 4 years ago by greiner

  • Resolution set to fixed
  • Status changed from reviewing to closed

https://hg.adblockplus.org/adblockpluschrome/rev/87348b585232

I created #2726 for reusing the texts from the Firefox version.

comment:12 Changed 4 years ago by greiner

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next

comment:13 Changed 4 years ago by Ross

  • Tester set to Ross

Add an "x" in the top-right corner of the notification.

Done / Working.

Upon clicking the "x", the notification content should be replaced with the following two links (see screenshot​):

Close this notification: Hide the notification
Stop showing notifications: Hide the notification and add "*" to Prefs.notifications_ignoredcategories

Done / Working.

The following options should be hidden by default and only be shown if Prefs.notifications_showui is set to true

Done / Working.

Add a menu item "Show useful notifications" to icon context menu's "Options" submenu. Clicking on this item should toggle the "*" entry in Prefs.notifications_ignoredcategories.

Done / Working.

Add a checkbox "Show useful notifications" to preferences page at "about:addons". This checkbox should toggle the "*" entry in Prefs.notifications_ignoredcategories.

Done / Working.

Tested with:
ABP 1.9.2.1469 / Chrome 44.0.2403.89 / Windows 7 x64
ABP 1.9.2.1469 / Opera 30.0.1835.125 / Windows 7 x64
(Also tested on OS X, need to pull version numbers from my VM).

Note: See TracTickets for help on using tickets.