Opened 5 years ago

Closed 5 years ago

#2209 closed defect (fixed)

Fixed positioned elements aren't highlighted correctly

Reported by: passbrains Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.9-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian, mapx, Ross Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6014926904623104

Description (last modified by Ross)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ACH-161

Environment

Windows + Vista 64bit + Chrome + English
ABP version Chrome Browser 1.8.12.1396

How to reproduce

  1. Install latest ABP extension on Chromw Browser
  2. Load web page https://www.tumblr.com/tagged/dark-photography
  3. Scroll down till u see sign in prompt.
  4. Click on ABP icon and select 'Block Element'
  5. Click on the prompt to select for blocking.
  6. Observe.

Observed behaviour

Highlight does not appear on selecting the prompt though add filter dialog appears after few seconds.

Expected behaviour

Selected element for blocking shall show highlighting on highlighting.

Attachments (1)

3668_1427049025_dark.jpg (162.4 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 24 Mar 2015 15:54:41 posted by Ross Green
Reproduced as described.

Chrome 40.0.2214.93 / Windows Vista x64 / ABP Build: 1.8.12.1401

comment:2 Changed 5 years ago by Ross

  • Description modified (diff)

This appears to be caused because of the use of transform3d on the prompt elements. Removing the transform3d from the style causes the [Block element] highlight to appear/work as expected.

comment:3 Changed 5 years ago by mapx

  • Component changed from Unknown to Platform

comment:4 Changed 5 years ago by mapx

  • Cc sebastian mapx added

comment:5 Changed 5 years ago by sebastian

  • Cc Ross added
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing
  • Summary changed from Highlight for selection does not appear for blocking prompt to Fixed positioned elements aren't highlighted correctly

This seems to be unrelated of the transform CSS property. However, there is a bug effecting elements using postion: fixed. Since #1755 the overlay will be fixed positioned as well if the element it is highlighting is fixed positioned. But the scroll offset is still added. So the overlay isn't correctly positioned (in this case outside of the visible area) if you scrolled down.

comment:6 Changed 5 years ago by sebastian

  • Owner set to sebastian

comment:7 Changed 5 years ago by sebastian

  • Priority changed from Unknown to P3
  • Ready set

comment:8 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.