Opened 5 years ago

Closed 4 years ago

#2222 closed defect (fixed)

ABP fails to send issue report (error code 404)

Reported by: arthur Assignee: matze
Priority: P1 Milestone:
Module: Infrastructure Keywords:
Cc: fred, arthur, greiner Blocked By:
Blocking: #2226, #2526 Platform: Unknown
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5285001339863040/

Description (last modified by philll)

Environment

Windows 8.1 Pro
Firefox 36.0.4
ABP 2.6.8

How to reproduce

  1. Go to http://adblockplus.org
  2. Click the ABP icon in top right corner
  3. Select "Report issue on this page"
  4. Choose "Other Issue"
  5. Click the "Next" button
  6. Check the checkbox and click the "Next" button
  7. Click the "Next" button again
  8. Check the "Anonymous submission" checkbox
  9. Click the "Send report" button

Observed behaviour

The issue report cannot be sent, an [abp_report.png HTTP 404 message is shown].

Expected behaviour

The issue report should be sent.

Attachments (1)

abp_report.png (17.0 KB) - added by arthur 5 years ago.

Download all attachments as: .zip

Change History (14)

Changed 5 years ago by arthur

comment:1 Changed 5 years ago by arthur

  • Description modified (diff)
  • Summary changed from ABP fails to send issue report to ABP fails to send issue report (error code 404)

comment:2 Changed 5 years ago by greiner

  • Component changed from Adblock-Plus-for-Firefox to Infrastructure
  • Platform changed from Firefox/Firefox Mobile to Unknown

I didn't see any changes regarding this in our extension and this issue also appears with Adblock Plus 2.6 which was released roughly a year ago. Therefore my assumption is that this is a server-side issue in Infrastructure (or otherwise in Sitescripts).

comment:3 Changed 5 years ago by philll

  • Description modified (diff)
  • Priority changed from Unknown to P1

comment:4 Changed 5 years ago by matze

  • Cc fred added
  • Owner set to matze
  • Ready set

comment:5 Changed 5 years ago by matze

  • Blocking 2226 added

comment:6 Changed 5 years ago by matze

  • Cc arthur added

comment:7 Changed 5 years ago by greiner

  • Cc greiner added

comment:8 Changed 5 years ago by matze

This issue has been hot-fixed today afternoon.

Tests with @arthur show that new issues have been submitted in the meantime, though we did not find two of my self-triggered test issues. We will check back on that in the summary tomorrow. If it worked as intended, a persistent version of the fix is going to review tomorrow.

comment:9 Changed 5 years ago by famlam

I can confirm that I today have received my digests again (for EL, ELD, ELG, EP, Social, Annoyances and AWRL)

comment:10 Changed 5 years ago by matze

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

The patch set has just been published, after verifying the changes in a local replica of the server.

Notes for the future:

In order to avoid accidental overrides, the include fastcgi_params; directive - if present - should always preceed any additional fastcgi_param ...;.

Also, we should update the configuration to use fascgi_split_path_info ...; instead of manually setting SCRIPT_FILENAME, SCRIPT_NAME, PATH_INFO or PATH_TRANSLATED (which then must precede the inclusion of the fastcgi_params file).

comment:11 Changed 4 years ago by matze

  • Review URL(s) modified (diff)

comment:12 Changed 4 years ago by matze

  • Blocking 2526 added

comment:13 Changed 4 years ago by matze

  • Resolution set to fixed
  • Status changed from reviewing to closed
  • Tester set to Unknown
Note: See TracTickets for help on using tickets.