Opened 5 years ago

Closed 5 years ago

#2254 closed defect (fixed)

"build.py docs --quiet" generates warnings

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone:
Module: Automation Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6215705351421952

Description

How to reproduce

Run ./build.py docs --quiet from the root of the adblockplus (Firefox) repository.

Observed behaviour

Following warnings are printed to stderr:

WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/appSupport.js, line 31
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/appSupport.js, line 267
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/appSupport.js, line 407
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/appSupport.js, line 694
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/appSupport.js, line 696
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/appSupport.js, line 698
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/customizableUI.js, line 27
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/filterStorage.js, line 231
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/filterStorage.js, line 614
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/filterStorage.js, line 626
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/filterStorage.js, line 638
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/requestNotifier.js, line 36
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/requestNotifier.js, line 37
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/requestNotifier.js, line 38
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/requestNotifier.js, line 62
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/requestNotifier.js, line 63
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/requestNotifier.js, line 64
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/subscriptionClasses.js, line 307
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/sync.js, line 309
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/synchronizer.js, line 311
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/ui.js, line 128
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/ui.js, line 161
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/ui.js, line 345
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/ui.js, line 425
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/ui.js, line 796
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/ui.js, line 801
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/ui.js, line 807
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/ui.js, line 1186
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/ui.js, line 1221
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/ui.js, line 1365
WARNING: JSDoc does not currently handle ArrowFunctionExpression nodes. Source file: /home/sebastian/src/adblockplus/lib/ui.js, line 1403

That is because we use arrow functions quite a lot. However, they aren't supported by JsDoc getting ignored, which isn't a problem as long as there aren't documented anyway.

Expected behaviour

If the --quiet switch is given, no output should be printed if jsdoc completes successfully.

Change History (2)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.