Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2255 closed defect (fixed)

IO.writeToFile() doesn't support ES6 generators

Reported by: mapx Assignee: sebastian
Priority: P1 Milestone: Adblock-Plus-2.6.10-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: sebastian, trev Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5825018483179520

Description (last modified by sebastian)

Environment

FF 37
ABP 2.6.9.3928 (ABP 2.6.9, stable is OK)

How to reproduce

-the lists are gone
-re-add the lists ==> aren't saved in the adblockplus folder (patterns.ini 0 bytes, elemhide.css 0 bytes)
-the hiding filters are useless
-I refreshed FF, reinstalled ABP, the same behaviour

Change History (8)

comment:1 Changed 3 years ago by mapx

lib/io.js was modified (issue 1602), could be the cause ?!

comment:2 Changed 3 years ago by mapx

  • Description modified (diff)

comment:3 Changed 3 years ago by sebastian

  • Owner set to sebastian

comment:4 Changed 3 years ago by sebastian

  • Description modified (diff)
  • Priority changed from Unknown to P1
  • Ready set
  • Summary changed from ABP 2.6.9.3928 completely broken to IO.writeToFile() doesn't support ES6 generators

Yep, this regression were introduced by moving to ES6 generators (#1602). Apparently, the new generators don't only use a different syntax, but also have a different API. You can't iterate over them using for (.. in ..) loops but have to use for (.. of ..) loops.

comment:5 Changed 3 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 3 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 3 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Firefox-next

comment:8 Changed 3 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.