Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2260 closed defect (fixed)

Icon doesn't change when disabling ABP

Reported by: arthur Assignee: sebastian
Priority: P1 Milestone: Adblock-Plus-2.6.10-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5643346198396928

Description

Environment

Firefox 37
ABP dev build 2.6.9.3929
Windows 8.1 Pro

How to reproduce

  1. Go to https://adblockplus.org/
  2. Disable ABP everywhere or jsut for adblockplus.org via the context menu

Observed behaviour

The icon stays red.

Expected behaviour

It should change to grey. It changes the colour when refreshing the page.

Change History (6)

comment:1 Changed 5 years ago by greiner

  • Cc sebastian added

I was able to reproduce this issue on Firefox 38. It appears to be a regression caused by this change.

comment:2 Changed 5 years ago by sebastian

  • Owner set to sebastian
  • Priority changed from Unknown to P2
  • Ready set

This regression was introduced by #1602, same issue as #2255 but different place.
There are still some for..in loops left that needs to be replaced with for..of loops.

comment:3 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 5 years ago by sebastian

  • Priority changed from P2 to P1

comment:5 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 5 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.