Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#227 closed defect (fixed)

Element hiding selection by mouse wheel broken

Reported by: arthur Assignee: trev
Priority: P4 Milestone: Element-Hiding-Helper-1.3.1
Module: Extensions-for-Adblock-Plus Keywords:
Cc: trev Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: yes
Review URL(s):

http://codereview.adblockplus.org/5671525202001920

Description

Environment

  • Firefox 28
  • Windows 8.1 Pro x64
  • Adblock Plus 2.5.1.3788
  • Element Hiding Helper 1.2.4a.453

How to reproduce

  1. Start element hiding selection.
  2. Select an element (do not click, just hover).
  3. Press Shift and scroll down with the mouse wheel.

Observed behaviour

Selection jumps directly to the last node (##HTML).

Expected behaviour

It should select the next parent node.

Forum topic

https://adblockplus.org/forum/viewtopic.php?f=11&t=11640

Attachments (1)

elemhidehelper-1.3.0.463.xpi (105.3 KB) - added by trev 5 years ago.
Test build

Download all attachments as: .zip

Change History (12)

comment:1 Changed 5 years ago by philll

  • Resolution set to worksforme
  • Status changed from new to closed

Works for me with both, ABP stable 2.5.1 and EMH stable 1.2.3 as well as ABP 2.6.0.3804 and 1.3.0.463. Tested at http://web.de

comment:2 Changed 5 years ago by arthur

  • Cc trev added

I have found the cause. I always increase the number of lines the mouse wheel should scroll with one notch in the mouse wheel settings. Not sure what the exact relation between the number and the selected element is though.

Wladimir, could this be made independently?

comment:3 Changed 5 years ago by trev

So I guess that your mouse is configured to generate multiple scroll events each time you use the mouse wheel. I'm not sure we can do much about that - other than maybe enforcing a particular time interval between the "wider" commands that are being triggered there.

Changed 5 years ago by trev

Test build

comment:4 Changed 5 years ago by trev

  • Priority changed from P5 to P4
  • Ready set
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Actually, it might be a wrong implementation in Element Hiding Helper after all. Could you test the build I attached and tell me whether the issue is fixed there?

comment:5 Changed 5 years ago by trev

  • Owner set to trev

comment:6 Changed 5 years ago by arthur

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Verified working set

Yay, it's working for me. :)

comment:7 Changed 5 years ago by trev

  • Resolution fixed deleted
  • Status changed from closed to reopened

No, not fixed - this was merely a test, not even reviewed yet.

comment:8 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from reopened to reviewing

comment:9 Changed 5 years ago by arthur

Whoops, you're right of course. Sorry!

comment:10 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:11 Changed 5 years ago by trev

  • Milestone set to Element-Hiding-Helper-next
Note: See TracTickets for help on using tickets.