Opened 4 years ago

Closed 4 years ago

Last modified 22 months ago

#2316 closed defect (duplicate)

Not able to block Feedback button

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: mapx, sebastian, Ross Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by mapx)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ACH-169

Environment

Windows + Vista 64bit + Chrome + English
ABP version Chrome build 1.8.12.1411

How to reproduce

  1. Install latest ABP extension on Chrome Browser
  2. Load web page   http://www.stuff.tv/features/11-secret-whatsapp-tricks-you-probably-didnt-know-about
  1. Click on ABP icon and select 'Block Element'
  2. Select  'Feedback' button for blocking. see screenshot
  3. Add filter.
  4. Refresh the page and observe.

Observed behaviour

Selected Feedback Button did not get bocked.

Expected behaviour

Selected element shall be blocked

Attachments (1)

3668_1428684408_back.jpg (108.4 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 14 Apr 2015 17:38:51 posted by Ross Green
Reproduced as described.

The feedback tab is a link inside a div with a background image applied via CSS for the "feedback" text and the colour set via the style attribute on the tag.

Couldn't figure out any obvious reason why the filter doesn't hide the element as expected.

Chrome 41.0.2272.118 / Vista x64 / ABP: 1.8.12.1414

Last edited 4 years ago by Ross (previous) (diff)

comment:2 Changed 4 years ago by mapx

  • Description modified (diff)

comment:3 Changed 4 years ago by mapx

  • Cc mapx added

comment:4 Changed 4 years ago by sebastian

  • Cc sebastian Ross added
  • Resolution set to duplicate
  • Status changed from new to closed

Yeah, as mapx suspected, there is a <style> element setting display: block !important for this element, overriding our CSS rule which attempts to hide that element. Therefore closing as duplicate of #242. There is not much we could do about it.

comment:5 Changed 22 months ago by Tips Burn

Last edited 22 months ago by mapx (previous) (diff)
Note: See TracTickets for help on using tickets.