Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#2327 closed defect (fixed)

Nginx apt key is added on every provisioning

Reported by: trev Assignee: trev
Priority: P4 Milestone:
Module: Infrastructure Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4615235449126912/

Description

How to reproduce

  1. Provision any server that has been provisioned before.

Observed behaviour

Nginx apt key is being downloaded and added even though it already exists in the system. That's because apt-key list lists this key as 7BD9BF62 rather than ABF5BD827BD9BF62 which Puppet will currently look for.

Expected behaviour

The existing key should be recognized.

Change History (3)

comment:1 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:3 Changed 3 years ago by abpbot

Note: See TracTickets for help on using tickets.