Opened 6 years ago

Closed 3 years ago

#233 closed change (rejected)

safari: No way to adjust settings, without having the ABP button in the toolbar.

Reported by: Redoubts Assignee:
Priority: P5 Milestone:
Module: User-Interface Keywords: externaldependency
Cc: trev, sebastian Blocked By:
Blocking: Platform: Safari
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

For ABP in Safari Beta,

There should be a way to adjust the settings by Going to Safari Preferences > Extensions. A similar workflow exists for Firefox, by going to Add-Ons > Extensions > Options, and I think this should be recreated for Safari.

Currently the only way to adjust ABP settings after install is to keep the ABP icon in the Toolbar, but I would rather not clutter my browser with extra buttons that don't get used regularly.

Change History (11)

comment:1 Changed 6 years ago by philll

  • Owner set to sebastian
  • Status changed from new to assigned

@sebastian: You might evaluate this.

comment:2 Changed 6 years ago by sebastian

  • Type changed from defect to change

Safari's settings panel is very limited. So most of our options UI can't be implemented that way. Also I would like to avoid implementing and maintaining two different option UIs.

However in order to provide another way to access to the options page, we could:

  • Add a checkbox to the settings panel, that will open the options page when toggled.
  • Add a context menu (right click into any page) entry, that opens the options page.
  • Provide a web page, that can be bookmarked, and will show the options page.

I'm not convinced yet which if any of those options should be the way to go.

Last edited 6 years ago by sebastian (previous) (diff)

comment:3 Changed 6 years ago by mapx

  • Summary changed from No way to adjust settings, without having the ABP button in the toolbar. to safari: No way to adjust settings, without having the ABP button in the toolbar.

comment:4 Changed 6 years ago by sebastian

  • Keywords externaldependency added

I have sent following feature request to Apple:

The Safari Extension Settings API is very limited. Hence a lot of extensions (like our extension "Adblock Plus") use an HTML page for their settings. But the only way to link your settings page is from the toolbar icon menu/popover.

However Safari users expect to find extension settings under Preferences -> Extensions. And some users even customize their toolbar in order to remove extension icons.

So please provide a more straight-forward way to access extension settings, like one of following:

  1. Add buttons to the list of UI controls available in the extension settings panel. So we can add a button that opens our options page.
  2. Allow HTML inside the extension settings panel. So rich configuration UIs can be implemented where they belong.
  3. Add an option to specify an options page to Info.plist, and automatically link the options page in the extensions settings panel, like Chrome does.

comment:5 Changed 6 years ago by philll

  • Status changed from assigned to new

The assigned state will be dropped by #403

comment:6 Changed 6 years ago by sebastian

I got following response from Apple:

Engineering has determined that your bug report is a duplicate of another issue and will be closed.

The open or closed status of the original bug report your issue was duplicated to appears in the yellow "Duplicate of XXXXXXXX" section of the bug reporter user interface. This section appears near the top of the right column's bug detail view just under the bug number, title, state, product and rank.

If you have any questions or concerns, please update your report directly here: http://bugreport.apple.com/.


So apparently somebody else has already issued the same feature request. And since Safari's issue tracker lets you only see your own issues, I can neither read nor follow the original feature request.

Also we have decided to not use any ugly hacks here, to work around Safari's limitations. But wait until Safari provides a decent solution, like those suggested in our feature request.

Last edited 5 years ago by sebastian (previous) (diff)

comment:7 Changed 6 years ago by trev

  • Cc trev added
  • Priority changed from Unknown to P5
  • Ready set

comment:8 Changed 5 years ago by philll

  • Platform set to Firefox

comment:9 Changed 5 years ago by philll

  • Platform changed from Firefox to Safari

comment:10 Changed 5 years ago by sebastian

  • Cc sebastian added
  • Owner sebastian deleted

comment:11 Changed 3 years ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed
  • Tester set to Unknown

With the traditional Adblock Plus Safari extension being phased out, in favor of a native app, not to mention the limitations of Safari which are unlikely to be lifted, this is becoming irrelevant.

Note: See TracTickets for help on using tickets.