Opened 5 years ago

Closed 4 years ago

#2331 closed defect (fixed)

Investigate missing Nagios mail

Reported by: matze Assignee: matze
Priority: P1 Milestone:
Module: Infrastructure Keywords:
Cc: trev, fhd, fred Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

We have noticed that "... lots of [Nagios] mails [are] not being delivered". This is obviously an issue for a while now; Wladimir confirmed that this happened even before we've migrated to the new e-mail address resp. mailing list.

Since Nagios is the one key component for us to monitor our infrastructure (and because one cannot monitor the Nagios frontend manually all the time, see #2163), this is considered rather critical.

Change History (5)

comment:1 Changed 5 years ago by matze

  • Priority changed from Unknown to P1

@fred I will need your help here; it's very possible that the mails are dropped at GMail for some reason, and I do not have admin access to our account(s?) there.

comment:2 Changed 5 years ago by trev

Well, maybe that's the reason?

Received-SPF: none (google.com: nagios@… does not designate permitted sender hosts) client-ip=88.198.7.4;

While we've set up SPF a while ago, it still doesn't apply to either Nagios or cron mail (except for server16 where Postfix configuration has been changed like we discussed a while ago).

comment:3 Changed 5 years ago by fred

I had a look at the Google Apps "Email Log Search" for e-mails from "nagios@…" and indeed there were many entries listed as "bounced".

Here are the details for one of these bounced messages:
Subject: RECOVERY Service Alert: download1.adblockplus.org/Bandwidth is OK
Sender: nagios@…
Recipient: mon...g@…
Date: Apr 16, 2015, 00:07
Message ID: <20150415220724.7140F7A0B87@…>
Message size: 1.66KB
Attachments: 0

Recipient details
mon...g@…
Apr 16, 2015, 00:07 Received from an SMTP server with IP address: 2a01:4f8:130:428d::2 (Not encrypted)
250 2.0.0 OK
Apr 16, 2015, 00:07 Received from an SMTP server
Apr 16, 2015, 00:07 Bounced
Message rejected by Google Groups. Please visit http://mail.google.com/support/bin/answer.py?hl=en&answer=188131 to review our Bulk Email Senders Guidelines.

So indeed GMail seems to regard some of the Nagios emails as SPAM.
Maybe adding an SPF-record for the subdomain server4.adblockplus.org will help.
Or alternatively masquerading the sender address of Nagios as "nagios@…".

comment:4 Changed 4 years ago by matze

I've just added an SPF record for Nagios mails today. This will become obsolete as soon as we've updated the Postfix configuration.

comment:5 Changed 4 years ago by matze

  • Resolution set to fixed
  • Status changed from new to closed
  • Tester set to Unknown

The SPF records actually improved the situation, and with the removal of the single-core filter-servers we actually can include all relevant existing servers with SPF without exceeding the lookup limits.

Still, setting up a central mail-server (#277) is the only complete solution.

Note: See TracTickets for help on using tickets.