Opened 5 years ago

Closed 5 years ago

#2379 closed defect (fixed)

[kick.py] Updating puppetmaster data should happen before resolving hosts

Reported by: trev Assignee: matze
Priority: P3 Milestone:
Module: Infrastructure Keywords:
Cc: fred, fhd Blocked By:
Blocking: #2382 Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6676867801153536

Description

How to reproduce

  1. Add a new host to the Puppet configuration.
  2. Run kick.py newhost

Observed behaviour

kick.py errors out because Puppet master doesn't know the host - the configuration change is in the repository, but the data on the Puppet master hasn't been updated yet.

Expected behaviour

kick.py should recognize the host and provision it.

Change History (5)

comment:1 Changed 5 years ago by trev

  • Component changed from Unknown to Infrastructure
  • Summary changed from Updating puppetmaster data should happen before resolving hosts to [kick.py] Updating puppetmaster data should happen before resolving hosts

comment:2 Changed 5 years ago by matze

  • Cc fred fhd added; matze removed
  • Owner set to matze
  • Priority changed from Unknown to P3
  • Ready set

comment:3 Changed 5 years ago by matze

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 5 years ago by matze

  • Blocking 2382 added

comment:5 Changed 5 years ago by matze

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.