Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#238 closed defect (fixed)

Opening new window progressively slows down when adblock plus is installed and enabled

Reported by: nanotube Assignee: greiner
Priority: P2 Milestone: Adblock-Plus-2.6-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: smultron45@… Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: yes
Review URL(s):

http://codereview.adblockplus.org/6231262318559232/

Description

Using Firefox 28, official 64bit mozilla build for linux from mozilla.org, on xubuntu linux 13.10 (saucy) 64bit. Problem tested to persist with Adblock plus release 2.5.1, as well as latest dev build as of the time of this writing, 2.5.1.3788.

The problem is that as I open and close new firefox windows during the session, new window opening becomes slower and slower, and uses more CPU, as time goes on. While initially new windows open near-instantaneously, after a couple days of light use (maybe 50-100 firefox windows having been opened and closed), it starts taking 1-3, then 3-5, then 5-7 seconds to open a new firefox window, and eats CPU. (Until eventually I give up and restart the session - though every indication suggests that it'll just keep getting worse.)

Upon detailed testing earlier today, I discovered the problem is tied explicitly to adblock plus. When the extension is installed and enabled, starting a new session, then even merely opening a few dozen windows at a time in quick succession then closing them, then repeating again, I notice the slowdown.

Steps to reproduce:

  1. install firefox :P
  2. create fresh firefox profile.
  3. install adblock plus latest release. doesn't matter if you enable any filters or not.
  4. start a new firefox session with this profile.
  5. hit ctl-n a couple dozen times to open a bunch of new firefox windows
  6. hit ctl-w same number of times to close them (but leave one running so as not to terminate the session)
  7. repeat steps 4 and 5, 3-5 times, to simulate a normal browsing session.
  8. as you do this, notice that opening new windows gradually slows down and eats more CPU.

Workaround:
going to tools->addons, and hitting 'disable' on adlbock plus, immediately resolves any new window slowness.
upon enabling it again, slowdown process starts from scratch.
this does not require restarting the firefox session.

I'd be happy to run any diagnostics to help troubleshoot the problem and solve it.

Change History (22)

comment:1 Changed 6 years ago by nanotube

Note that opening new tabs is unaffected, only new windows are.

comment:2 Changed 6 years ago by philll

  • Resolution set to worksforme
  • Status changed from new to closed

I tried this out on three machines now, but were not able to notice any slowdown at least visibly. Even at one of my Windows VMs with only one assigned core of my i5 2,6Ghz CPU, this works smoothly after the 20th window and third attempt of opening and closing them all. Despite having noticed my Iceweasel at Debian crashing with or without ABP after too many windows reliably, this seems to work fine with Ubuntu and Win7. Also my guess that my SSD speeds things up to an unnoticable delay could be proved wrong, as the Ubuntu trial was at a native i3 non-SSD system.

comment:3 Changed 6 years ago by woslv

I reported a similar problem in the forums but on Windows 7 x64. New tabs are okay but new windows open slower and slower. Removing the AdBlock button from the Firefox toolbar while leaving the extension enabled eliminates the problem. I replicated the problem on two systems, one of which had fresh installs of Firefox 28 and AdBlock, meaning it's not an issue with my PC and should be easy to reproduce. I don't need to leave Firefox running for days like nanotube. I can reproduce it in just a few seconds by running Firefox, opening 30 windows, closing them all, and then opening a new window. It takes 1 - 2 seconds and gets worse depending on how many windows have been opened and closed previously. I have a fast i7-2600K CPU and Windows and Firefox are on an SSD. Should I log a new defect?

comment:4 Changed 6 years ago by nanotube

  • Resolution worksforme deleted
  • Status changed from closed to reopened

woslv: thank you for confirmation. i don't /need/ a few days either - i just said that it happens within a few days of normal browsing. if i deliberately open and close a bunch of windows, i see it also right away, as i described in my bug report steps to reproduce.

thanks for the toolbar button trick - just tried it and it removes the problem, this is great!

philll, i am reopening the issue, since it appears i'm not alone in experiencing it. not sure what other conditions you are missing to reproduce the bug, we can work on a process of elimination to figure it out. e.g., did you use the binary from mozilla.org, or whatever came from your distro's repositories? (since you mentioned iceweasel, my guess is the latter).

comment:5 Changed 6 years ago by woslv

Okay, I didn't read the whole thing. I should also say that the slowdown only started to bother me in March, and I'm very sensitive to stuff like this. It could be specific to Firefox 28, which was released just recently.

comment:6 Changed 6 years ago by nanotube

My recollection is also that it started about a month or two ago. It is not just ff28 - I definitely recall it being a problem with firefox 27 as well, and hoping that ff28 will fix it. Not sure about ff26, but ff 27 for sure.

I think maybe we should also try testing older adblock versions. I'll try testing old adblock releases and see if I can pinpoint the one where the problem started. For your reference, here's a nice list of old dev builds of adblock: https://downloads.adblockplus.org/devbuilds/adblockplus/ if you want to also give it a try.

comment:7 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:8 Changed 6 years ago by nanotube

OK, I did a binary search through the last several months of dev builds. The problem occurs on builds 2.4.1.3767 and later, not on earlier builds. So it seems the issue was introduced in build 3767.

For your reference, the changelog for 3767 says:

#3767: 2014-02-13 14:12 +0100 Thomas Greiner
     Implemented anti-adblock message notification

woslv: could you please confirm my findings? basically, test with build 3766 and confirm that problem does not occur when adblock button is in the toolbar, then test with build 3767 and confirm that it does?

comment:9 Changed 6 years ago by woslv

You're exactly right. The problem started in 3767. Thanks for debugging.

comment:10 Changed 6 years ago by nanotube

woslv: thank you for confirmation. I guess now we wait for someone on the dev side to help us figure out the actual root of the issue ....

philll (or anyone else): please let us know if there is anything else we can do to help you reproduce the issue on your side.

comment:11 Changed 6 years ago by philll

  • Owner set to greiner
  • Status changed from reopened to assigned

@greiner: I still cannot reproduce this, no matter how hard I try. Could you please have a look at it and also check the code again for flaws that are capable of inducing that behaviour?

comment:12 Changed 6 years ago by greiner

I was able to reproduce that issue and am going to work on it.

comment:13 Changed 6 years ago by philll

  • Priority changed from Unknown to P2

comment:14 Changed 6 years ago by greiner

  • Review URL(s) modified (diff)
  • Status changed from assigned to reviewing

comment:15 Changed 6 years ago by greiner

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:16 Changed 6 years ago by nanotube

yay, thank you greiner!
i'll test once the 3789 devbuild is out.

comment:17 Changed 6 years ago by nanotube

tested with 3789 dev build - problem appears to be gone.
thank you greiner, and thank you philll.

comment:18 Changed 6 years ago by greiner

  • Verified working set

comment:19 Changed 6 years ago by woslv

New windows aren't opening slowly now, but the AdBlock button takes about a second to appear on the toolbar after Firefox starts. It's distracting because the search box and the rest of the toolbar suddenly shift. nanotube, do you see the same thing?

comment:20 Changed 6 years ago by greiner

Could you please create a new issue for that? Please also check whether you can observe this behavior in revision 3766 or lower.

comment:21 Changed 6 years ago by woslv

You're right, it's unrelated and started in 3788. I'm creating a new issue.

comment:22 Changed 6 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
Note: See TracTickets for help on using tickets.