Opened 4 years ago

Closed 4 years ago

#2466 closed defect (fixed)

Add filter dialog stops responding after repeatedly blocking twitter profile images

Reported by: passbrains Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.9-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian, mapx, Ross Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4767690782670848

Description (last modified by Ross)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ACH-173

Environment

Windows + Vista 64bit + Chrome + English
ABP version Chrome build 1.8.12.1423

How to reproduce

  1. Install latest ABP extension on Chrome Browser
  1. Load page  http://www.designmantic.com/
  1. Scroll down the page.
  1. Block the image by  right click as shown in screenshot.
  1. Repeat step 4 multiple times and observe (try to do this quickly in succession).

Observed behaviour

Add filter pop up does not come up.
-OR-
The add filter dialog does appear but its [Add] and [Cancel] buttons do not respond.

Expected behaviour

Add filter dialog shall come on invoking block element on an image.

Attachments (1)

3668_1429894115_free.jpg (103.5 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 29 Apr 2015 08:27:31 posted by Timo Scherf
In my case the twitter box / frame is not working and empty with every browser I use (ABP switched off).
So I can not try to reproduce this, because the site itself seems to have some problems.

2 - 07 May 2015 00:30:37 posted by Ross Green
I can reproduce this (or at least something very similar).

If a user Right Click > Blocks the Twitter feed profile images repeatedly and quickly in succession, the Add filter dialog appears to "block" somehow. It can either block hidden and not appear at all, or block displayed but not respond at all to the add or cancel buttons being clicked.

Also, I could not reproduce this on Windows 8.1 but could on Windows Vista.

ABP 1.8.12.1423
Chrome 41.0.2272.101 / Windows Vista x64

comment:2 Changed 4 years ago by Ross

  • Description modified (diff)
  • Summary changed from Add filter pop up does not appear on selecting block element to Add filter dialog stops responding after repeatedly blocking twitter profile images

comment:3 Changed 4 years ago by mapx

  • Cc sebastian mapx added
  • Component changed from Unknown to Platform

comment:4 Changed 4 years ago by sebastian

  • Cc Ross added

When I right click that image and choose "Block element", the dialog shows up, but moving the mouse pointer around will keep highlighting other elements. Clicking again, will bring up another dialog. The buttons on the first dialog won't respond any longer. This a regression introduced with #2298 (1.8.12.1413). This might be related to the issue others experienced here.

comment:5 Changed 4 years ago by sebastian

  • Owner set to sebastian
  • Priority changed from Unknown to P3
  • Ready set

It turned out that Ross and myself were in fact talking about the same issue. Since #2298 the element selection were activated when using "Block element" fro mthe context menu, however it was only disabled in the top level frame where the dialog is shown. This could cause multiple dialogs showing up. But only the most recent dialog did actually respond.

Last edited 4 years ago by sebastian (previous) (diff)

comment:6 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:7 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.