Opened 6 years ago

Closed 5 years ago

#247 closed defect (fixed)

Bad blocking rule suggestion

Reported by: arthur Assignee: trev
Priority: P2 Milestone: Adblock-Plus-2.6.1-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: smultron45@…, famlam Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5121539439591424

Description

Environment

Windows 8.1 Pro x64
Firefox 28
Adblock Plus 2.5.1.3788

How to reproduce

  1. Go to http://query.nytimes.com/search/sitesearch/#/obama/since1851/allresults/1/allauthors/newest/
  2. Try to block this resource:
    http://www.google.com/uds/afs?q=obama&client=newyorktimes-cse&adsafe=high&adpage=0&r=s&oe=UTF-8&ie=UTF-8&fexp=21404&format=n7&ad=n0&nocache=1701396445032500&num=0&output=uds_ads_only&v=3&adext=as1%2Csr1&rurl=http%3A%2F%2Fquery.nytimes.com%2Fsearch%2Fsitesearch%2F%23%2Fobama%2Fsince1851%2Fallresults%2F1%2Fallauthors%2Fnewest%2F#slave-1-1
    

Observed behaviour

The given suggestion for a rule is the following:

google.com/uds/afs#slave-1-1?*

If you doubleclick it, it changes into

|google.com/uds/afs#slave-1-1?*

Expected behaviour

The suggested filter should be as follows:

||google.com/uds/afs?q=obama&client=newyorktimes-cse&adsafe=high&adpage=0&r=s&oe=UTF-8&ie=UTF-8&fexp=21404&format=n7&ad=n0&nocache=1701396445032500&num=0&output=uds_ads_only&v=3&adext=as1%2Csr1&rurl=http%3A%2F%2Fquery.nytimes.com%2Fsearch%2Fsitesearch%2F%23%2Fobama%2Fsince1851%2Fallresults%2F1%2Fallauthors%2Fnewest%2F#slave-1-1

Forum topic

https://adblockplus.org/forum/viewtopic.php?f=11&t=10678

Change History (6)

comment:1 Changed 6 years ago by arthur

  • Ready set

comment:2 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:3 Changed 6 years ago by philll

  • Cc famlam added

comment:4 Changed 5 years ago by trev

  • Owner set to trev
  • Priority changed from Unknown to P2

Yes, looks like we don't clear the hash part of the URLs - we definitely should.

comment:5 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.