Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2473 closed defect (fixed)

Interaction with ABP doesn't work

Reported by: fhd Assignee: rjeschke
Priority: P1 Milestone: Adblock-Browser-for-Android-beta-1.0.0.2015052021
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5391942804307968/

Description

Environment

Adblock Browser revision 08d7790aed21 on Android 5.0.2 on a Nexus 9.

How to reproduce

There are multiple bugs caused by the underlying issue, but here is one that's particularly quick to reproduce:

  1. Go to any remote website, e.g. https://adblockplus.org
  2. Open the hamburger menu

Observed behaviour

The Block Ads on this Site menu item is disabled.

Expected behaviour

The Block Ads on this Site menu item should be enabled - it's only supposed to be disabled for local sites.

Managing subscriptions or enabling/disabling Acceptable Ads in the settings page doesn't work either - the communication between app and extension is obviously not working anymore.

Change History (7)

comment:1 Changed 4 years ago by fhd

  • Owner set to rjeschke

comment:2 Changed 4 years ago by fhd

This is a regression introduced by #2352.

comment:3 Changed 4 years ago by rjeschke

  • Platform changed from Unknown to Android
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 4 years ago by rjeschke

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 4 years ago by fhd

  • Sensitive unset

comment:7 Changed 4 years ago by philll

  • Platform changed from Android to Adblock Browser for Android

See #2673

Note: See TracTickets for help on using tickets.