Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2482 closed defect (fixed)

An update is found even when on the latest version

Reported by: fhd Assignee: fhd
Priority: P2 Milestone: Adblock-Browser-for-Android-beta-1.0.0.2015052021
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by fhd)

Environment

Adblock Browser for Android 1.0.0.20150508144955 on a Nexus 9 running Android 5.0.2.

How to reproduce

  1. Ensure you're on the latest version (currently that's the one above)
  2. Open the about page by entering about: in the URL bar
  3. Touch Check for Updates

Observed behaviour

An update is found and will be downloaded.

Expected behaviour

No update should be found - we're already on the latest version after all.

Change History (8)

comment:1 Changed 4 years ago by fhd

I've found that AppConstants.MOZ_APP_BUILDID (under obj-*/mobile/android/base/generated/preprocessed/org/mozilla/gecko/AppConstants.java) differs from the actual build ID under obj-*/config/buildid. The former ID is used in the Android layer, the latter in the Gecko layer.

It looks like the issue is that the build process is generating AppConstants.java before updating the build ID. Most certainly an upstream issue, Mozilla probably didn't notice it so far.

Version 1, edited 4 years ago by fhd (previous) (next) (diff)

comment:2 Changed 4 years ago by fhd

  • Summary changed from Update checks seem to detect an update when on the latest version to An update is found even when on the latest version

comment:3 Changed 4 years ago by fhd

  • Description modified (diff)

comment:4 Changed 4 years ago by fhd

  • Resolution set to fixed
  • Status changed from new to closed

Turns out the build number is fine if you do a clobber, i.e. full rebuild. Relatively annoying, but it's better than to mess around with the build system.

comment:5 Changed 4 years ago by fhd

  • Owner set to fhd

comment:6 Changed 4 years ago by fhd

  • Milestone set to Flux-next

comment:7 Changed 4 years ago by fhd

  • Sensitive unset

comment:8 Changed 4 years ago by philll

  • Platform changed from Android to Adblock Browser for Android

See #2673

Note: See TracTickets for help on using tickets.