Opened 3 years ago

Closed 13 months ago

Last modified 5 months ago

#2512 closed defect (fixed)

A square to mark and unmark is displayed on the side of "None".

Reported by: passbrains Assignee: diegocarloslima
Priority: P3 Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: sven Blocked By: #3820
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29341314/

Description (last modified by fhd)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ADR-4

Environment

Samsung + Galaxy S3 + Android 4.3

How to reproduce

  1. Install the browser.
  2. Go to Settings -> Adblocking -> Adblocking
  3. Click on the filter list which was selected to make selection empty.
  4. Go back. Click on Adblocking.

Observed behaviour

A square is displayed on the side of "None".

Expected behaviour

"None" is displayed without any square on the side of it.

Attachments (1)

3766_1431450530_andrNone.png (124.9 KB) - added by passbrains 3 years ago.

Download all attachments as: .zip

Change History (14)

Changed 3 years ago by passbrains

comment:1 Changed 3 years ago by fhd

  • Component changed from Unknown to Flux
  • Description modified (diff)
  • Platform changed from Firefox/Firefox Mobile to Android
  • Priority changed from Unknown to P3
  • Ready set

While this was so far by design, I can see how it doesn't really make sense, let's get rid of the check box for "None". Also note how the "None" item is not disabled in the screen shot, that's actually quite confusing that way.

comment:2 Changed 3 years ago by fhd

  • Cc sven added
  • Ready unset

Let's hear Sven's opinion first actually :)

comment:3 Changed 3 years ago by sven

I agree, there shouldn't be a check-box.

comment:4 Changed 3 years ago by rjeschke

I really do not understand the problem here, as the entry is disabled. Still, will try to come up with some custom UI element to put there in replacement.

comment:5 Changed 3 years ago by fhd

  • Sensitive unset

comment:6 Changed 2 years ago by philll

  • Platform changed from Android to Adblock Browser for Android

See #2673

comment:7 Changed 19 months ago by diegocarloslima

  • Owner set to diegocarloslima
  • Tester set to Unknown

comment:8 Changed 19 months ago by diegocarloslima

  • Status changed from new to reviewing

comment:9 Changed 19 months ago by diegocarloslima

  • Review URL(s) modified (diff)

comment:10 Changed 14 months ago by diegocarloslima

  • Ready set

comment:12 Changed 13 months ago by diegocarloslima

  • Blocked By 3820 added
  • Milestone set to Adblock-Browser-for-Android-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:13 Changed 5 months ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • There is no longer a checkbox next to 'none' when no filter list is enabled. Instead, the box now shows 'None - Please select one below'.

ABB adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

Note: See TracTickets for help on using tickets.