Opened 3 years ago

Closed 11 months ago

Last modified 5 months ago

#2513 closed change (fixed)

Adblock Browser does not display chosen filter lists as active right away

Reported by: philll Assignee: diegocarloslima
Priority: P5 Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: fhd, sven Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29345373/

Description

Environment

Asus Nexus 7
Android 5.1.1
Adblock Browser 1.0.0.20150508204826

How to reproduce

  1. Tap the three dot menu
  2. Tap Settings
  3. Tap Adblocking
  4. Tap Adblocking
  5. Unselect all lists shown under the "Active for websites in" section
  6. Go back to the previous menu
  7. Tap the Adblocking menu (Configure your filter subscriptions) again
  8. Select any list from below

Observed behaviour

The checkbox at the selected list is checked but the "Active for websites in" section stays empty.

Expected behaviour

All offered filter lists should always be shown in the "Other languages" section (I wonder, whether that is an appropriate naming, as it already assumes that there is a choice active) and if selected, also in the "Active for websites in" section right away. If a list is deselected, it should be removed from that section right away and unchecked in the "Other languages" section.

Change History (16)

comment:1 Changed 3 years ago by fhd

  • Cc sven added
  • Platform changed from Firefox/Firefox Mobile to Android

As far as I'm concerned the behaviour makes sense this way - it's hard for the user to undo adding/removing a language if it jumps far up or down the screen right after they toggle it. But there's on situation in which I could see this as misleading: When there are no lists enabled and you add one. Then it says None under Active for websites in, even though some lists are active.

What do you think, Sven?

comment:2 Changed 3 years ago by philll

As I wrote in the expected behaviour section, I don't expect it to "jump up" and thus disappear from the area that I am viewing and rather be displayed on top additionally.

comment:3 Changed 3 years ago by fhd

Sorry, missed that. Yeah that'd avoid the jumping, but is duplicate better?

I've checked how it works in iOS, and there we actually have this jumping behaviour - is that by design though?

comment:4 Changed 3 years ago by sven

To keep this issue updated: only fhd saw this behavior in iOS, because of his screen-sharing meeting. I didn't specified that behavior, but i would like to see their implementation first to decide whether this approach makes sense or not.

comment:5 Changed 3 years ago by philll

@fhd: I wonder where you looked at at iOS? I only see one huge list of subsriptions that get an additional check arrow one you tap them, no different section where something could jump to?

comment:6 Changed 3 years ago by rjeschke

Keep in mind, that we are on Android. Copying iOS behaviour is the wrong way to do UX on Android.

Android has it's own style guides, look and feel, ... so please refrain from trying to build an iOS app on Android.

Also: having two different lists is complicated enough (and also not often seen on Android), so we really should avoid causing any more confusion (for users and developers) by duplicating entries or jumping around.

comment:7 Changed 3 years ago by sven

Keep in mind, that we are on Android. Copying iOS behaviour is the wrong way to do UX on Android.
Android has it's own style guides, look and feel, ... so please refrain from trying to build an iOS app on Android.

Don't worry. I'm aware of that and consider that :-)

Last edited 3 years ago by sven (previous) (diff)

comment:8 Changed 3 years ago by fhd

  • Sensitive unset

comment:9 Changed 3 years ago by rjeschke

  • Priority changed from Unknown to P3
  • Type changed from defect to change

comment:10 Changed 2 years ago by philll

  • Platform changed from Android to Adblock Browser for Android

See #2673

comment:11 Changed 2 years ago by fhd

  • Priority changed from P3 to P5
  • Tester set to Unknown

So, based on the discussion here, we probably don't actually want that. Setting to P5.

comment:12 Changed 18 months ago by diegocarloslima

  • Owner set to diegocarloslima

comment:13 Changed 18 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:15 Changed 11 months ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:16 Changed 5 months ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • When following the steps above, the selected filter list no longer stays newly selected in the 'other languages', but is actively moved to the 'Active for websites in...' section after selection.

ABB adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

Note: See TracTickets for help on using tickets.