Opened 5 years ago

Closed 5 years ago

#2514 closed change (fixed)

[issue tracker issues1] Allow owner, reporter and CC to view confidential issues

Reported by: sebastian Assignee: philll
Priority: P3 Milestone:
Module: Infrastructure Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5154590563500032

Description (last modified by sebastian)

Background

Currently, issues marked as "Confidential" on Trac can only be viewed and commented on by users with sufficient permissions (i.e. staff). However, sometimes confidential issues are reported by regular users or involve such. That's for example when discussing ways to counter circumvention on particular websites.

What to change

Configure the already included SensitiveTicketsPlugin in our issue tracker, running on issues1, that is https://issues.adblockplus.org (this website), to allow the reporter, owner and users in CC to access the issue regardless of their permissions and whether the issue is confidential.

Change History (3)

comment:1 Changed 5 years ago by philll

  • Description modified (diff)
  • Owner set to philll
  • Review URL(s) modified (diff)
  • Summary changed from [Trac] Allow owner, reporter and CC to view confidential issues to [issue tracker issues1] Allow owner, reporter and CC to view confidential issues

comment:2 Changed 5 years ago by sebastian

  • Description modified (diff)

comment:3 Changed 5 years ago by philll

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.