Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2515 closed defect (fixed)

Platform page layout is broken in IE8

Reported by: Ross Assignee: kzar
Priority: P2 Milestone:
Module: Websites Keywords:
Cc: trev Blocked By:
Blocking: #2035, #2499 Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: yes
Review URL(s):

http://codereview.adblockplus.org/5699656273100800/

Description

Environment

Browser / OS: IE 8.0.6001 / Windows XP

Page: https://beta.adblockplus.org/en/firefox
(seems to effect all "platform pages" too, such as "/en/safari" and so on)

How to reproduce

  1. Visit platform page in IE8.
  2. Observe page layout.

Observed behaviour

Page layout appears to break and causes elements to shift out of position and overlap each other.

See IE8-BadLayoutTop.jpg and IE8-BadLayoutBottom.jpg.

Expected behaviour

Page layout to work correctly.

See Chrome-WorkingLayout.jpg.

Attachments (4)

IE8-BadLayoutTop.jpg (334.2 KB) - added by Ross 5 years ago.
IE8-BadLayoutBottom.jpg (317.0 KB) - added by Ross 5 years ago.
Chrome-WorkingLayout.jpg (300.7 KB) - added by Ross 5 years ago.
ie8-weirdness.png (19.1 KB) - added by kzar 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by Ross

Changed 5 years ago by Ross

Changed 5 years ago by Ross

comment:1 Changed 5 years ago by kzar

  • Owner set to kzar

I can reproduce as described, working on old site but broken on beta.adblockplus.org

comment:2 Changed 5 years ago by kzar

Problem seems to be that div#content gets a width of 680px instead of 990px. Not sure why yet, possibly something to do with the order CSS files are included.

comment:3 Changed 5 years ago by trev

  • Blocking 2499 added
  • Cc trev added
  • Priority changed from Unknown to P2
  • Ready set

Changed 5 years ago by kzar

comment:4 Changed 5 years ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 5 years ago by kzar

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 5 years ago by Ross

  • Verified working set

Fixed.

Tested by:
Checking updated beta.adblockplus.org in IE8.

Note: See TracTickets for help on using tickets.