Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2518 closed defect (fixed)

Regression: <noscript> tag is no longer located in <body> section

Reported by: greiner Assignee: trev
Priority: P3 Milestone:
Module: Websites Keywords:
Cc: saroyanm Blocked By:
Blocking: #2035 Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: yes
Review URL(s):

http://codereview.adblockplus.org/6240082344280064/

Description

Background

This is a regression from #1651 which required the <noscript> tag to be moved to the <body> section to avoid parsing issues with the Facebook crawler. Note that due to #2078 the steps described in #1651 can currently not be followed.

How to reproduce

  1. Search for <noscript> at view-source:https://adblockplus.org/en/firefox
  2. Search for <noscript> at view-source:https://beta.adblockplus.org/en/firefox

Observed behaviour

  • Code in (1) shows that <noscript> tag is located in <body>
  • Code in (2) shows that <noscript> tag is located in <head>

Expected behaviour

  • Both sources show that <noscript> tag is located in <body>

Change History (6)

comment:1 Changed 5 years ago by saroyanm

  • Blocking 2035 added
  • Priority changed from Unknown to P3
  • Ready set

comment:2 Changed 5 years ago by saroyanm

  • Cc saroyanm added

comment:3 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 5 years ago by trev

  • Owner set to trev

comment:5 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 5 years ago by Ross

  • Verified working set

Fixed.

Tested by:
Serving web.adblockplus.org and checking the page source.

web.adblockplus.org / r72

Note: See TracTickets for help on using tickets.