Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2529 closed defect (duplicate)

ABP logo overlaps header links in some RTL languages

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Websites Keywords:
Cc: kzar, saroyanm Blocked By:
Blocking: #2035 Platform: Unknown
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Chrome / 42.0.2311.135 (But any browser)

How to reproduce

  1. Visit https://beta.adblockplus.org/de/
  2. Observe the ABP logo does not overlap header links.
  3. Select the language drop-down and select the first entry (Arabic).
  4. Observe the ABP logo overlaps the header links.

Observed behaviour

The ABP logo overlaps the installation header link when the site is displayed in Arabic (see attached screenshots).

Note: This does not currently occur on the live site (adblockplus.org)

Expected behaviour

The ABP logo should not overlap links in the header.

Attachments (2)

Logo-RTL-Beta.jpg (280.0 KB) - added by Ross 5 years ago.
Logo-RTL-Live.jpg (276.8 KB) - added by Ross 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by Ross

Changed 5 years ago by Ross

comment:1 Changed 5 years ago by Ross

  • Cc kzar saroyanm added

comment:2 Changed 5 years ago by kzar

  • Resolution set to duplicate
  • Status changed from new to closed

I can reproduce this, it's caused by the extra English flags next to the menu links. I actually think the way the new site behaves is better here though, the links in question _will_ default to English when clicked and I guess the old system wasn't smart enough to detect that.

I don't think this has anything to do with RTL, just the fact that most pages don't have translations for the language.

So really this is a duplicate of #2304 and not a blocker for the migration.

comment:3 Changed 5 years ago by Ross

Ah, didn't realise it was caused by the flags. Will keep an eye on #2304 instead.

Note: See TracTickets for help on using tickets.