Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2536 closed defect (worksforme)

Unblocked advertisements open a new tab that immediately closes upon clicking them.

Reported by: MSI Team Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

=== Environment ===
Adblock Plus version: 1.8.12
Browser version: Chrome 43.0.2357.65 beta
OS version: Windows 8.1 (6.3)
Filterlists: EasyList, EasyPrivacy, Adblock Warning Removal List, Fanboy's Social Blocking List, Malware Domains

=== How to reproduce ===
See the steps to reproduce the problem on https://crbug.com/485071

=== Observed behavior ===
Upon clicking some (not all) unblocked advertisements, a new tab opens and immediately closes. The issue cannot be reproduced with Adblock Plus disabled.

=== Expected behavior ===
The tab should not open, or better, the ad should be blocked (if Adblock Plus knows to close the tab it should block the page element).

See https://crbug.com/485071

Change History (7)

comment:1 follow-up: Changed 4 years ago by sebastian

  • Cc sebastian added

I cannot reproduce the issue.

  • Please try the development build. Does the issue persist there?
  • Which filter lists / settings are you using?
  • Can you provide a screen recording showing the issue?

comment:2 in reply to: ↑ 1 Changed 4 years ago by sebastian

Replying to sebastian:

  • Which filter lists / settings are you using?

I just realized that your filter lists are listed in the issue description above. However, with those filter lists the Facebook feed is blocked, and I can't reproduce the issue either.

comment:3 Changed 4 years ago by MSI Team

Can you try the environment specified by the crbug issue?

comment:4 Changed 4 years ago by greiner

I cannot reproduce this issue using:

Ubuntu 14.04
Chrome 43.0.2357.65 (64-bit)
Adblock Plus 1.8.12

  • Adblock Warning Removal List
  • EasyList
  • EasyPrivacy
  • Fanboy's Social Blocking List
  • Malware Domains

In my tests the Facebook widget is hidden by the social blocking list and even when disabling that one the links inside the widget are all pointing to bit.ly. I couldn't make out any tracking redirects besides that one which could've caused this issue.

comment:5 Changed 4 years ago by sebastian

  • Resolution set to worksforme
  • Status changed from new to closed

Closing as worksforme, as two developers weren't able to reproduce the issue. If the issue is still reproducible, feel free to attach a screen recording, and reopen the issue.

comment:6 Changed 4 years ago by Ross

I cannot reproduce this either with the same lists installed. The social list is either blocked/hidden or functions as expected (opens the selected article in a new tab).

ABP 1.8.12.1430
Chrome 43.0.2357.65 / Windows 8.1 x64

comment:7 Changed 4 years ago by MSI Team

This is an intermittent issue.

Note: See TracTickets for help on using tickets.