Opened 6 years ago

Closed 5 years ago

Last modified 6 months ago

#255 closed defect (fixed)

[Firefox Mobile] Opening settings from first-run page doesn't work on Android

Reported by: trev Assignee: saroyanm
Priority: P2 Milestone: Adblock-Plus-2.6.1-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: smultron45@… Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6286955629248512/

Description

See https://bugzilla.mozilla.org/show_bug.cgi?id=947162, the link to settings on the first-run page doesn't work on Android. In fact, it causes really ugly side-effects as it tries to open a XUL dialog - something the Firefox Mobile doesn't really support.

The problem is firstRun.js running UI.openFiltersDialog() for this link. The best solution would probably be changing UI.openFiltersDialog() implementation - on Firefox Mobile it should show Addons Manager's inline preferences.

Change History (7)

comment:1 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:2 Changed 5 years ago by saroyanm

  • Owner set to saroyanm
  • Status changed from new to assigned

comment:3 Changed 5 years ago by saroyanm

I've noticed that BrowserOpenAddonsMgr method is not available in firefox mobile.

Seams like Firefox for Mobile don't have a method to show options page of specific Add-on,

Looks like the options pages are being loaded during about:addons page load only:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/aboutAddons.js#323

Anyway there is a bug in Bugzilla about creation of standard way of opening Addon Manager page:
https://bugzilla.mozilla.org/show_bug.cgi?id=730127
https://bugzilla.mozilla.org/show_bug.cgi?id=715716

For now maybe we can disable Acceptable Ads by just clicking on disable link and show a notification to user that the AA has been disabled.

comment:4 Changed 5 years ago by philll

  • Status changed from assigned to new

The assigned state will be dropped by #403

comment:5 Changed 5 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
Note: See TracTickets for help on using tickets.