Opened 4 years ago

Closed 4 years ago

#2552 closed defect (rejected)

AdblockPlus doesn't block YouTube ads in Firefox when e10s is enabled

Reported by: prr Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev, greiner, mapx, patfla Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by mapx)

Environment

Windows 7
Firefox 40.0a2
AdBlockPlus 2.6.9

STR:

  1. go to youtube.com
  2. find a video with an ad (or go to https://www.youtube.com/watch?v=JCjsbImXiyg).
  3. Watch the video--but an ad will appear first, even though ABP is enabled.
  4. Disabling the multiprocess option in FF 40 (Options/General/Enable multiprocess Firefox), and then restarting, will allow the ad to be blocked by ABP.

Observed behaviour

Ad at start of video will show.

Expected behaviour

Ad at start of video will not show.

forum thread: https://adblockplus.org/forum/viewtopic.php?f=1&t=31117

Change History (8)

comment:1 Changed 4 years ago by mapx

  • Cc trev greiner mapx added
  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Description modified (diff)
  • Platform changed from Unknown to Firefox/Firefox Mobile

comment:2 Changed 4 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

comment:3 follow-up: Changed 4 years ago by prr

Today I installed the newest development build from the link https://adblockplus.org/en/development-builds#installation and I'm not seeing ads since I've installed it. I was also seeing ads at the top of Youtube search results, but after this update I'm not seeing those either. Perhaps the 18 May update (#3938) resolved this?

Last edited 4 years ago by prr (previous) (diff)

comment:4 in reply to: ↑ 3 Changed 4 years ago by patfla

Replying to prr:

Today I installed the newest development build from the link https://adblockplus.org/en/development-builds#installation and I'm not seeing ads since I've installed it. I was also seeing ads at the top of Youtube search results, but after this update I'm not seeing those either. Perhaps the 18 May update (#3938) resolved this?

Per your post, I just installed the latest dev version of ABP (and have the latest FF dev) and I don't see that the problem has gone away. Still get starting ads at:

https://www.youtube.com/watch?v=JCjsbImXiyg

when e10s is enabled.

Neither do I see on this ticket or elsewhere ( https://hg.adblockplus.org/adblockplus ) that work has been done so I wouldn't expect the problem to be fixed.


I'm a developer and while I've never done FF (or add-on) work before out of curiosity I downloaded and built the ABP code and have set up a working env (e.g. try out the Add-on debugger). I assume the place to start is with the .js files under lib so I've spent a small amount of time studying them.

comment:5 Changed 4 years ago by mapx

  • Cc patfla added

comment:6 Changed 4 years ago by prr

I've been playing around with e10s being enabled and not--must have been watching when I'd disabled it.

I tried it just now and saw ads on top of search results, as well as an ad to start that video I linked to. Sorry for the false hope there. :(

comment:7 Changed 4 years ago by mapx

the last aurora version 40.0a2 (2015-05-23) is working fine with the multi process enabled

comment:8 Changed 4 years ago by mapx

  • Resolution set to rejected
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.