Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#256 closed defect (fixed)

Home/End keys are broken when editing a filter

Reported by: arthur Assignee: trev
Priority: P3 Milestone: Adblock-Plus-2.6.1-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: smultron45@…, trev Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4834220086132736/

Description (last modified by arthur)

Environment

Latest Nightly (works on Firefox 28)
Adblock Plus 2.5.1.3788
Windows 8.1 Pro x64

How to reproduce

  1. Open filter preferences
  2. Edit a custom filter
  3. Press the home and end key

Observed behaviour

Nothing happens.

Expected behaviour

The cursor should jump in front of and at the end of the filter.

Forum topic

https://adblockplus.org/forum/viewtopic.php?f=11&t=21597

Change History (8)

comment:1 Changed 6 years ago by arthur

  • Description modified (diff)

comment:2 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:3 Changed 5 years ago by trev

  • Cc trev added

I can reproduce this - works fine in Firefox 29, broken in the current nightly.

comment:4 Changed 5 years ago by trev

This seems to be a regression from https://bugzilla.mozilla.org/show_bug.cgi?id=950373 (http://hg.mozilla.org/mozilla-central/rev/b57f9be43a50 in particular), it affects Up and Down keys as well.

comment:5 Changed 5 years ago by trev

  • Keywords externaldependency added

Filed https://bugzilla.mozilla.org/show_bug.cgi?id=1007680 on this. Unfortunately, the way the tree widget works I don't see what we can do on our end here.

comment:6 Changed 5 years ago by trev

  • Keywords externaldependency removed
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Ouch, the issue is really https://bugzilla.mozilla.org/show_bug.cgi?id=777832 here and we are already working around it - but only for the keypress event, not keydown.

comment:7 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Owner set to trev
Note: See TracTickets for help on using tickets.