Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2561 closed defect (fixed)

Installing extensions should not be allowed until official support lands

Reported by: greiner Assignee: rjeschke
Priority: P2 Milestone: Adblock-Browser-for-Android-beta-1.0.0.2015081632
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4819695857303552/

Description

Environment

CyanogenMod 11.0
Android 4.4.4
Adblock Browser 1.0.0

How to reproduce

  1. Open Adblock Browser
  2. Click on the "Adblock Plus" panel in the new tab page
  3. Click on the green "Install" button on adblockplus.org

Observed behaviour

The browsers asks whether the extension should be downloaded and then whether it should be installed. Affirming both questions installs the extension without any possibility of reverting that due to #2415.

Expected behaviour

In the best case we'd show a message instead explaining that extensions are not yet supported. Otherwise we should at least prevent the existing dialog from popping up.

Change History (6)

comment:1 Changed 4 years ago by rjeschke

  • Owner set to rjeschke
  • Platform changed from Unknown to Android
  • Priority changed from Unknown to P2
  • Ready set

comment:2 Changed 4 years ago by rjeschke

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 4 years ago by rjeschke

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 4 years ago by fhd

  • Milestone set to Adblock-Browser-for-Android-next

comment:6 Changed 4 years ago by philll

  • Platform changed from Android to Adblock Browser for Android

See #2673

Note: See TracTickets for help on using tickets.