Opened 5 years ago

Closed 5 years ago

#2568 closed defect (fixed)

Missing images on blog

Reported by: greiner Assignee: trev
Priority: P1 Milestone:
Module: Websites Keywords: blog
Cc: saroyanm, trev Blocked By:
Blocking: #2035 Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5930700549128192/
http://codereview.adblockplus.org/5330257947131904/

Description (last modified by greiner)

How to reproduce

  1. Go to the landing page of one of our blogs: Releases, Development Builds, Blog
  2. Notice the separator between individual blog posts
  3. Notice the output in the JavaScript console
  1. Go to this blog post
  2. Notice the image on the top of the post
  3. Notice the output in the JavaScript console

Observed behaviour

Expected behaviour

  • (2,5) No placeholder image is shown
  • (3,6) No 404 error is shown

Change History (8)

comment:1 Changed 5 years ago by greiner

  • Description modified (diff)
  • Summary changed from Missing image 1.gif on blog to Missing images on blog

comment:2 Changed 5 years ago by saroyanm

  • Cc saroyanm added
  • Priority changed from Unknown to P3
  • Ready set

comment:3 Changed 5 years ago by saroyanm

  • Cc trev @… added

@Wladimir I can't find this images in anwiki repo I think this images were located in our old Anwiki server, but were outside of repo, I've noticed most of the images from the blog posts were gone, do we still have access to the old server files ? Would it be possible to migrate all images from "images" directory to our new server ? Hope they are still available.

comment:4 Changed 5 years ago by greiner

  • Cc @… removed

comment:5 Changed 5 years ago by trev

  • Owner set to trev

These images belong to the blog, not to Anwiki. They are still on the legacy server of course, the one that is hosting the blog. Unfortunately, we already have a bunch of images in the CMS under static/images/. So I think what we need to do here is:

  • Move all images in the CMS under static/images/ to static/img/.
  • Make https://adblockplus.org/images/ proxied to the legacy server.

comment:6 Changed 5 years ago by trev

  • Priority changed from P3 to P1
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Broken functionality - definitely P1.

comment:7 Changed 5 years ago by trev

  • Review URL(s) modified (diff)

comment:8 Changed 5 years ago by trev

  • Blocking 2035 added
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.