Opened 4 years ago

Closed 4 years ago

#2570 closed defect (duplicate)

Microsoft Edge on Windows 10 Mobile is detected as Android

Reported by: oleksandr Assignee:
Priority: Unknown Milestone:
Module: Infrastructure Keywords:
Cc: saroyanm, sebastian, sven, sergz Blocked By: #2844
Blocking: #2843 Platform: Internet Explorer
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by oleksandr)

Environment

Microsoft Edge on Windows Phone 10 (aka Windows 10 Mobile) on Nokia Lumia 925

How to reproduce

  1. Go to https://adblockplus.org/

Observed behaviour

The landing page suggests to install ABP for Android.

Expected behaviour

The MS Edge on Windows 10 Mobile should be detected as MS Edge and directed to a special MS Edge landing page, which will be created in #2779

I've been told that the User-Agent string of the browser will remain as it is now. Specifically:
Mozilla/5.0 (Windows Phone 10.0; Android 4.2.1; NOKIA; Lumia 925) AppleWebkit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Mobile Safari/537.36 Edge/12.0

Change History (11)

comment:1 Changed 4 years ago by saroyanm

  • Cc sven added

The MS Edge on Windows 10 Mobile should be detected as MS Edge and directed to a special MS Edge landing page.

Special MS Edge Landing Page ?
@Ollie Can you please be more descriptive here ? Do we already have that page ?
If no, I think make sense to align with @Sven I think.

Last edited 4 years ago by saroyanm (previous) (diff)

comment:2 Changed 4 years ago by sebastian

I agree with Sven. In order to implement this issue, it would need a design and texts for that landing page. That is why I asked you to pitch that issue to Sven and Ann-Lee before posting it here. Also what's about the email field you mentioned on IRC? The issue description isn't mentioning it at all.

Also I don't see how showing mistakenly the Android landing page to Windows Phone users is related to a landing page for Microsoft Edge, which is a desktop browser as well. So if we add a landing page for Edge, we should probably also show it to desktop users.

comment:3 Changed 4 years ago by oleksandr

This issue is only about incorrect detection on Microsoft Edge on Windows Phone. The landing page will be a separate issue, which I will reference here later, after some discussions. Until then this issue can be in "not ready" state.

comment:4 Changed 4 years ago by oleksandr

  • Blocked By 2779 added
  • Component changed from Websites to Infrastructure
  • Description modified (diff)
  • Tester set to Unknown

comment:5 Changed 4 years ago by oleksandr

  • Blocked By 2779 removed

comment:6 Changed 4 years ago by oleksandr

  • Blocked By 2779 added

comment:7 Changed 4 years ago by saroyanm

I think it make sense to reconsider this project, new homepage for Edge users It's not a good idea. Because it can affect our SEO and doesn't feels to be user friendly, we should think about our users first:

So I'll suggest to go with one of this solutions:

  • Show message to the users that are using Microsoft Edge and point to the landing page where they can subscribe.
  • have subscription form on the homepage (maybe instead of install button), because user still would be able to use the current homepage.

I would go with the 1-st option, wile from my perspective is most user friendly, because users can still download whatever platform they want, even they will not success installing it, but we want affect user experience we initially had.

comment:8 Changed 4 years ago by sergz

  • Cc sergz added

comment:9 Changed 4 years ago by oleksandr

  • Blocked By 2844 added; 2779 removed
  • Blocking 2874 added

comment:10 Changed 4 years ago by oleksandr

  • Blocking 2843 added; 2874 removed

comment:11 Changed 4 years ago by saroyanm

  • Resolution set to duplicate
  • Status changed from new to closed

The changes described here can be handled by #2874 already, so marking this as duplication.

Note: See TracTickets for help on using tickets.