Opened 5 years ago

Closed 3 years ago

#2574 closed defect (fixed)

Increase Textpattern configured max_url_len to 2000

Reported by: greiner Assignee: fred
Priority: P3 Milestone:
Module: Infrastructure Keywords: blog
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by ferris)

Old title: Getting HTTP 503 response when following link to blog post

How to reproduce

Follow this link

Observed behaviour

Receive HTTP response with status code 503 (Service Unavailable) in the header and "Nice try." in the body.

Expected behaviour

Either ignore the query string parameters and serve the page as usual or do a HTTP 301 server-side redirect to the canonical page.

Background

This link was found in a Google+ post created by xda-developers.

In any case, using the 503 status code is not appropriate for this situation according to RFC 2616.

Change History (3)

comment:1 Changed 3 years ago by ferris

  • Description modified (diff)
  • Owner set to trev
  • Summary changed from Getting HTTP 503 response when following link to blog post to Increase Textpattern configured max_url_len to 2000
  • Tester set to Unknown

The problem/feature is that the our blog engine has an attack prevention mechanism that blocks requests that are longer than 200 characters (max_url_len). This can be changed under "Advanced Preferences of your Textpattern admin panel.".

I'll assign this to trev, assuming he can change this setting. 2000 should a be a reasonable value these days?

In light of this, perhaps 400 would've been a better response code, but I don't want to start hacking inside the Textpattern instance.

comment:2 Changed 3 years ago by fred

  • Owner changed from trev to fred
  • Priority changed from Unknown to P3
  • Ready set

comment:3 Changed 3 years ago by fred

  • Resolution set to fixed
  • Status changed from new to closed

Since I also have admin (publisher) access to Textpattern I reassigned this to myself and changed the setting to 2000 chars as suggested by Ferris.

Now I can open the link/url mentioned in the description, so I close the ticket.

Note: See TracTickets for help on using tickets.