Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2576 closed defect (fixed)

runserver.exe error: no module named urllib2

Reported by: lisabielik Assignee: sebastian
Priority: P2 Milestone:
Module: Websites Keywords: runserver
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: yes
Review URL(s):

http://codereview.adblockplus.org/4843664727605248/

Description

Receiving an error (attached) on the following:
-Win 8.1
-latest version of runserver.exe from Drive

How to reproduce

  1. Make changes to any page on adblockplus.org (within HgTortoise).
  2. Save changes.
  3. Open runserver.exe.
  4. Enter the URL into a browser tab.

...

Observed behaviour

The error is stated in the runserver command prompt. I cannot view any changes because of the error.

Attachments (1)

runservererror.png (11.4 KB) - added by lisabielik 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by lisabielik

comment:1 Changed 4 years ago by sebastian

  • Priority changed from Unknown to P2
  • Ready set
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

For reference, globals/get_browser_versions.py imports urllib2. However, that module isn't bundled with runserver.exe. This regression was introduced by #2432. In order to fix it, we can simply use the urllib module instead.

comment:2 Changed 4 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:3 Changed 4 years ago by Ross

  • Verified working set

This specific error is fixed for me with the latest version of web.adblockplus.org. Another error now occurs which is covered by #2578.

web.adblockplus.org / r87
runserver.exe / March 20th from Drive.

Note: See TracTickets for help on using tickets.