Opened 5 years ago

Closed 5 years ago

#2578 closed defect (fixed)

runserver.exe error: no module named dom

Reported by: Ross Assignee: sebastian
Priority: P2 Milestone:
Module: Sitescripts Keywords: runserver
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6236544096534528

Description (last modified by sebastian)

Environment

web.adblockplus.org / r87
March 20th runserver.exe from Drive / Windows 8.1

How to reproduce

  1. Run runserver.exe from web.adblockplus.org directory.
  2. Attempt to visit the server (http://127.0.0.1:5000)
  3. Observe page reports error.
  4. Observe runserver.exe console reports error.

Observed behaviour

Since xml.dom.minidom is used by web.adblockplus.org/globals/get_browser_versions.py, but isn't bundled with runserver.exe, following exception is raised:

Traceback (most recent call last):
File "C:\Program Files\Python\lib\wsgiref\handlers.py", line 85, in run
File "f:\cms\build\runserver\out00-PYZ.pyz\cms.bin.test_server", line 62, in handler
File "f:\cms\build\runserver\out00-PYZ.pyz\cms.bin.test_server", line 54, in get_data
File "f:\cms\build\runserver\out00-PYZ.pyz\cms.utils", line 42, in process_page
File "f:\cms\build\runserver\out00-PYZ.pyz\cms.converters", line 280, in init
File "<string>", line 9, in <module>
ImportError: No module named dom

Expected behaviour

The xml.dom.minidom module should be bundled with runserver.exe that no error occurs and the content is served.

Change History (5)

comment:1 Changed 5 years ago by Ross

  • Description modified (diff)

comment:2 Changed 5 years ago by sebastian

  • Component changed from Websites to Sitescripts
  • Description modified (diff)
  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 5 years ago by sebastian

  • Owner set to sebastian

comment:4 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 5 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.