Opened 4 years ago

Closed 4 years ago

#2579 closed defect (invalid)

rambler.ru loads forever

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: arthur, sebastian, Lain_13 Blocked By:
Blocking: Platform: Unknown
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-224

Environment

Windows + 8 64bit + Opera + Russian
ABP version 1.8.12.1429

How to reproduce

1) Navigate to www.rambler.ru
2) Site loading for an unlimited  period of time.

Observed behaviour

Site loading unspecified period of time.

Expected behaviour

Site loading normally.

Attachments (1)

7058_1431970875_rambler.jpg (476.1 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by sebastian

  • Cc arthur sebastian added
  • Description modified (diff)
  • Platform changed from Opera to Unknown
  • Summary changed from ABP breaks sites. For example rambler.ru non-stop loading. to rambler.ru loads forever

Reproduced, that rambler.ru seems to load (the spinner in the tab keeps showing) forever. However, the website seems to be functional, and according to the Networks panel all requests are finished. The behavior is the same on Chrome and Firefox. The issue doesn't occur if you disable Adblock Plus on that website, or if you disable EasyList. I consider this a filter list issue.

comment:2 Changed 4 years ago by arthur

  • Cc Lain_13 added

Hey Lain,

Could you take a look at this?

Thanks!

comment:3 Changed 4 years ago by Lain_13

Hi,

I can't reproduce this problem but most likely due to recent changes which I did there.
So, just update installed filter lists and it should work normally.

BTW, actually it loads rather quickly but adfox scripts are installed there in a way that page does not end up in a closed for write state and remain in the open state. In such a case spinner is displayed like it has to load something yet but never loads anything since adfox scripts were blocked and there are nothing else to load. It's a rather common issue with adfox and some other ads networks. :(

Last edited 4 years ago by Lain_13 (previous) (diff)

comment:4 Changed 4 years ago by sebastian

I can still reproduce it with latest EasyList.

comment:5 Changed 4 years ago by Lain_13

The fix was implemented in the RU AdList. So, you need either combined RuAdList+EasyList or separate version of RU AdList. Both available here: https://forums.lanik.us/viewtopic.php?f=102&t=22512
Also, combined version is available in Adblock's options as one of the default filters lists to subscribe.

Last edited 4 years ago by Lain_13 (previous) (diff)

comment:6 Changed 4 years ago by sebastian

So this issue is caused by EasyList, but RuAdlist has a fix for it. I see.

@Arthur: Are you aware of that? Do you think it would make sense to have the fix in EasyList instead?

comment:7 Changed 4 years ago by Lain_13

Just in case here is my fix for this issue:
@@/getCode?$script,domain=rambler.ru
@@/getCodeTest?$script,domain=rambler.ru

comment:8 Changed 4 years ago by arthur

Usually false postives are fixed in the respective language filter list if it's a recommended/default one. So I think it's fine how it is.

comment:9 Changed 4 years ago by sebastian

  • Resolution set to invalid
  • Status changed from new to closed

Ok, fair enough.

Note: See TracTickets for help on using tickets.