Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2601 closed defect (duplicate)

AdBlock Plus unresponsive when starting chrome

Reported by: type40TARDISat221b Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: mapx, greiner, sebastian, Arthur Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

OS: Windows 7 Ultimate (64-Bit)
Browser: Google Chrome Version 43.0.2357.81 m
ABP Version: 1.8.12
ABP Lists: EasyList, EasyPrivacy, Anti-adblock warning filters, "non-intrusvive" ads blocked.

How to reproduce

  1. Boot and log into Windows
  2. Load Google Chrome
  3. Navigate to any website with ads
  4. Click ABP Helper Icon on toolbar in upper right corner. Icon unresponsive but rest of google chrome functions as normal
  5. OCCASIONAL TEMPORARY FIX: Disable, close chrome, restart chrome then re-enable ABP.

...

Observed behaviour

Google Chrome is completely responsive without any lag, however ABP fails to block ads. When I attempt to click on the helper icon, the icon and ABP are unresposnive. I am only able to get ABP to function when disabling ABP, terminating chrome completely, restarting chrome and re-enabling. Sometimes even this doesn't work, and I have to uninstall then re-install. I have had to do the latter twice over the past week.

Expected behaviour

ABP to load, and function as an enabled extention as per it's usual functions without having to uninstall/reinstall or disable/reenable.

Change History (8)

comment:1 Changed 4 years ago by type40TARDISat221b

CORRECTION TO OS INFORMATION: Windows 7 Ultimate (64-Bit) (Version 6.1 Build 7601: Service Pack 1)

comment:2 Changed 4 years ago by mapx

  • Cc mapx added

see this thread and try all the steps:
https://adblockplus.org/forum/viewtopic.php?f=10&t=31460

comment:3 Changed 4 years ago by mapx

probably you should try the last dev build (where the filter matcher was optimized):
https://chrome.google.com/webstore/detail/ldcecbkkoecffmfljeihcmifjjdoepkn/details

disable / remove the stable build 1.8.12

ultimately due to some heavy regex filters it could happen isssues like yours

Last edited 4 years ago by mapx (previous) (diff)

comment:4 Changed 4 years ago by mapx

  • Cc greiner sebastian added

comment:5 Changed 4 years ago by mapx

see also
http://forums.lanik.us/viewtopic.php?f=64&t=23096

it should be released 1.8.13 as in the last dev build it was optimized the filterClasses stuff (matcher) as for #2177 (2.6.9 for firefox has already the optimized thing)

Last edited 4 years ago by mapx (previous) (diff)

comment:6 Changed 4 years ago by sebastian

  • Cc Arthur added

Sorry, I were away for the past week. But I heard from a couple of users who were experiencing massive performance issues, presumably due to that filter change.

We probably should have a release soon, which is going to be Adblock Plus 1.9. However, given the amount of changes in there, I feel that's still too early and that we should test them a little more.

@Arthur: Can you confirm this is caused by this change? Any chance to simplify that regexp?

Last edited 4 years ago by sebastian (previous) (diff)

comment:7 Changed 4 years ago by mapx

fanboy has modified / simplified that filter so probably for now it's ok ...

comment:8 Changed 4 years ago by sebastian

  • Resolution set to duplicate
  • Status changed from new to closed

OK, closing the issue now, as it can either be considered a duplicate of #2177 or a filter list issue.

Note: See TracTickets for help on using tickets.