Opened 5 years ago

Closed 5 years ago

#2607 closed defect (fixed)

currentVersion pref not cleared on uninstallation

Reported by: fhd Assignee: fhd
Priority: P2 Milestone:
Module: Automation Keywords:
Cc: Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4777306409140224/

Description

Environment

All Firefox extensions using buildtools revision 370 or later, for example Adblock Plus devbuild 2.6.9.3944.

How to reproduce

  1. Install Adblock Plus devbuild 2.6.9.3944.
  2. Uninstall Adblock Plus again.
  3. Open about:config and filter for extensions.adblockplus.currentVersion.

Observed behaviour

The extensions.adblockplus.currentVersion pref is still present.

Expected behaviour

The extensions.adblockplus.currentVersion pref should have been removed during uninstallation.

Change History (5)

comment:1 Changed 5 years ago by fhd

This is a regression caused by #2444.

comment:2 Changed 5 years ago by fhd

  • Owner set to fhd

comment:3 Changed 5 years ago by fhd

  • Status changed from new to reviewing

comment:4 Changed 5 years ago by fhd

  • Review URL(s) modified (diff)

comment:5 Changed 5 years ago by fhd

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.