Opened 5 years ago

Last modified 3 years ago

#264 reopened defect

ABP attributes are added to every element in contentEditable elements

Reported by: alfonsoml Assignee:
Priority: P3 Milestone:
Module: Adblock-Plus-for-Internet-Explorer Keywords: ie_devbuild_1.2
Cc: eric@…, mapx Blocked By:
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Windows 7, IE11
Current versión of ABP installed today

How to reproduce

  1. Go to http://ckeditor.com/demo
  2. In the editor, Click the "HTML Source" button
  3. Look at the HTML

Observed behaviour

Every element has an additional attribute "abp"

<h1 abp="847"><img abp="848" alt="Saturn V carrying Apollo 11"
 class="right" src="http://c.cksource.com/a/1/img/sample.jpg" /> 
Apollo 11</h1>
...

Expected behaviour

Just like it happens in Firefox, don't modify the HTML (at least stop when a contentEditable element is found)

<h1><img alt="Saturn V carrying Apollo 11" class="right"
 src="http://c.cksource.com/a/1/img/sample.jpg" />
 Apollo 11</h1>

Change History (17)

comment:1 Changed 5 years ago by mapx

comment:2 Changed 5 years ago by mapx

  • Cc smultron45@… added

comment:3 Changed 5 years ago by mapx

  • Summary changed from adb attributes are added to every element in contentEditable elements to ABP attributes are added to every element in contentEditable elements

comment:4 Changed 5 years ago by mapx

  • Summary changed from ABP attributes are added to every element in contentEditable elements to [IE] ABP attributes are added to every element in contentEditable elements

comment:5 Changed 5 years ago by philll

  • Priority changed from Unknown to P2
  • Ready set

comment:6 Changed 4 years ago by eric@…

  • Summary changed from [IE] ABP attributes are added to every element in contentEditable elements to ABP attributes are added to every element in contentEditable elements

comment:7 Changed 4 years ago by mapx

  • Cc eric@… mapx added; smultron45@… removed

comment:8 Changed 4 years ago by philll

  • Keywords ie_devbuild_1.2 added

comment:9 Changed 4 years ago by philll

  • Platform set to Firefox

comment:10 Changed 4 years ago by oleksandr

  • Priority changed from P2 to P3

comment:11 Changed 4 years ago by oleksandr

  • Platform changed from Firefox to Internet Explorer

comment:12 Changed 3 years ago by Mailkov

I think this issue must be closed because the defect is not reproducible.

comment:13 Changed 3 years ago by mapx

  • Resolution set to worksforme
  • Status changed from new to closed

comment:14 follow-up: Changed 3 years ago by asdf

  • Resolution worksforme deleted
  • Status changed from closed to reopened

This is extremely easy to reproduce, and still a problem. Had this occur with a port of ckeditor, and had to build in my own custom parsing to get rid of the abp attributes being added. Please make sure you are in IE11 in windows 7 and follow the reproduction steps.

comment:15 in reply to: ↑ 14 ; follow-up: Changed 3 years ago by alfonsoml

Replying to asdf:

This is extremely easy to reproduce, and still a problem. Had this occur with a port of ckeditor, and had to build in my own custom parsing to get rid of the abp attributes being added. Please make sure you are in IE11 in windows 7 and follow the reproduction steps.

If you're using CKEditor you can add this plugin and forget about AdBlock Plus: http://ckeditor.com/addon/noabp

comment:16 in reply to: ↑ 15 Changed 3 years ago by asdf

Replying to alfonsoml:

If you're using CKEditor you can add this plugin and forget about AdBlock Plus: http://ckeditor.com/addon/noabp

Thanks Alfonso, the plugin works. That being said this should still be fixed.

comment:17 Changed 3 years ago by uhclem42

I have experienced this repeatedly on a Win7 laptop with IE11 and ABP, using the Joomla JCE editor.
Any editing of articles in the Joomla editor will cause the underlying HTML document to be peppered with abp="1234" flags. They are not visible in the WYSIWYG editor, but if you flip into an HTML mode, they're all over. Some of these land in places that local HTML tag processing stops working. (e.g. "Read more..." breaks) That's how I noticed.

Note: See TracTickets for help on using tickets.